Extremely high CPU useage after today's dist-upgrade

I’m going to be brutally honest and say I have no idea what I’m doing half the time on Linux. Why I chose a development branch less then a month after converting from Windows is something I ask myself on a daily basis… To save myself the embarrassment, I am going to downgrade to the LTS or 16.10 but before I give up I wanna try seeing what I can do about it, Or at the very least, try to understand what happened.

I run apt-get update. upgrade, and dist-upgrade and usually restart on a daily basis, Whatever I just upgraded today has made my AMD processor go absolutely insane on the usage, Compiz seemed to be causing it. So I changed my Window Manager in MATE Tweak to Marco (Compton GPU Compositor) and the problem persists.

Is there a way to see what was upgraded after closing the terminal window?

Edit: After looking around bit and watching my CPU usage spike during windows being moved, I noticed my nvidia drivers are not working properly, I am currently on the x.org driver for some reason and every time I try to check the proprietary drivers, It clicks back to x.org.

Can you please identify the responsible process?

sudo apt install htop

This is a terminal process viewer, on the top you should see the process with active CPU usage by default.
Also please test by turning off compositing (Use Marco - No Compositor) and report back.

1 Like

Hi Ouroumov, Thank you for replying.
After a rough night, The problem seems to have been solved, Long story short : It was a problem with the nvidia driver after updating something, It wouldn’t install last night (Something about libc6-dev) but had no problem today.

I do have a few questions about it if you don’t mind, But if you’d like to skip that and make sure we’re all good, Everything is back to normal and running perfectly fine :slight_smile:

Did we have some sort of major update to 17.04 last night? Possibly a kernel update? (I could be wrong, But I don’t recall being on 4.10 before) because my working theory is I updated after a major release of the kernel (or something else?) but before a compatible nvidia driver could be uploaded to the repository. The driver refused to install no matter what I did, Apparently due to libc6-dev. Even after constant reboots, purging it and manually downloading the driver or trying an older one, Nothing would work… But today it downloaded no problem when using ‘apt-get install nvidia-375’

Would this sound like a plausible break down of events? Or do I have no idea what I’m talking about. I fear the latter :confused:

1 Like

It’s very possible there was a kernel / libc update.
Actually two days ago was the release of the final Beta of Zetsy, which is the final milestone before release on 13th of April.

1 Like

Sweet, Thanks for the tip. At least it gives me a little more confidence to know I’m not completely ass-backwards when it comes to understanding linux in general. I literally switched last month from Windows 7 out of sheer boredom and dying to learn everything I can about it.

Thank you for replying and reading to my newbie ramblings, See ya around :slight_smile:


Well damn, you don't often hear that. And for you to jump into the fray with a more-or-less unstable alpha release. Respect.

1 Like