Failure to boot after BIOS update

Hi

I am having real trouble booting to my Thinkpad X230. This is a recent development and I have no idea how to debug it. Can someone recognise the symptoms and help me debug it please?

I have had the Thinkpad dual-booting Win7 & Ubuntu for a few years (since 14.04) without any issues whatsoever. Recently, I’ve decided to upgrade from 16.04 to 18.04.1. A fresh install later and all was well.

I don’t use the Win7 partition very often but I had to log in soon after the upgrade to 18.04.1. Once on Windows, I accepted the BIOs critical upgrade suggested by the Lenovo software manager: upgrading from 2.70 to 2.73.

Since then Ubuntu stopped booting other than in rescue mode. This is supper annoying because I loose control over the brightness of the display, which is set to its minimum, and I can barely see what I am doing.

I have tried the following (unsuccessfully)

  1. Downgrade back to BIOS 2.70 (it seems that not all components of the upgrade have actually been downgraded)

  2. Installed Kubuntu 18.04, Ubuntu Mate 18.10 (the current version on the laptop)

Any help is greatly appreciated
Thanks

I have yet to solve the problem with the Thinkpad x230 failing to consistently boot to UM. Is there anyone in the community who might be able to help me debug and get to the bottom of this please.

I have been able to boot into Ubuntu Mate 18.04 & 18.10 (using an older kernel 4.18.0-11) every 3rd (or so) time so long as the laptop is plugged into mains. The laptop hapilly runs off of the battery once UM has booted (the battery is fine).

The partition with Win7 always boots just fine. I have tried a fresh installation with a brand-new hard-drive but faced the exact some problems right after the 1st boot post-install. This suggests to me that the hard-drive is also fine.

The problem is that booting up regularly freezes with messages such as (see images below):

[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] ERROR [CRTC:39:pipe A] flip_done timed out

and

systemd-journal[333]: Failed to write entry (21 items, 602 bytes), ignoring: Read-only file system

Other times I get to the log in screen but the desktop freezes (mouse & keyboard) right after logging in.

In both instances of problems only a hard reset seems to do.

Today I have tried to install UM 19.04 several times but ended up aborting the installation attempts because the installer wouldn't consistently see the hard drive.

I am really stuck, not even knowing how to debug the problem so any help would be greatly appreciated.
Many thanks

I should'a made a note of the flip done timed out business when it first happened on 16.04. Same fix - add video=SVIDEO-1:d in grub.

see https://askubuntu.com/questions/893817/boot-very-slow-because-of-drm-kms-helper-errors
https://askubuntu.com/questions/914970/more-on-system-settings-hang

This is a bug. To avoid delay you can use a workaround. From your terminal run:

sudo pluma /etc/default/grub

Then add the kernel boot parameter: video=SVIDEO-1:d, so it will look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

Then
sudo update-grub
sudo reboot

Edit: See this link for more information -

https://bbs.archlinux.org/viewtopic.php?id=218581&p=3

Thanks for the suggestion but unfortunately it doesn't seem to work in my case.

Can anyone suggest the necessary steps to debug this issue? I have access to logs given that I am able to boot up the system after n attempts. Where should I look and what should I look for?

Thanks