Fatal error installing warcraft III

Hello mates,

I am totally annoyed about this problem. It's not the first time I install that game, but it is about that freaking error. (I have ubuntu mate 16.04)
Last time I did it, after using the classic ubuntu, I was even more amazed, because just using wine I discovered it was even not necessary to correct the video size, various parameters etc. I just clicked on the icon like that damn billy's os. But now I don't know what is the problem.

ps. I tried different times on two pcs
another interesting thing I don’t understand is that the default path it creates is on windows7 (i have a dual boot with it)

What warcraft 3 use Warcraft III: Reign of Chaos or Warcraft III: The Frozen Throne
Use playonlinux program. -> https://www.playonlinux.com
do not use system wine. Report warcradt 3 errors in https://bugs.winehq.org/

You can check what wine version in warcraft working in -> https://appdb.winehq.org/objectManager.php?sClass=application&iId=897

oh thanks! now I try, but meanwhile can you tell me why it worked before and now I have these problems?

Maybe Wine is updated??

wtf, and is it even possible that what was ok now is dead?

yes it can possible. This is exactly why I use playonlinux program. In this way I can get around this problem. playonlinux is using own program-specific prefix. Using the program is easy. There can do their own installation programs, or use ready-made.

totally no idea of that… or better, I know that an update could be just garbage… it could slow down… but totally destroys is ridiculous.
anyway I tried
Error in POL_Wine
crashed

:frowning: too old installer. What warcaft you using, maybe im making updated installer.

LOL
damn technology… it worked better my nokia 3310 haha
I’ll try to do download it via terminal

one minute and new installer is done. You try this. https://github.com/lahtis/playonlinux/blob/master/testing/Warcaft3

-> Tools -> run a local script

I am sorry man, but I dont understand a line from your nerd link haha
I just know it failed again… and hurray for ‘updates’…

update software list in software botique
failed again

it worked! using wine ad add to the application window warcraft.exe

1 Like

Does the game work? At some point, Blizzard updated the game for it to work on modern PCs (i.e. Windows 7-10) and it broke compatibility with Wine. Last time I tried it, it crashed with an error like yours. Has it been fixed?

I said yes man, I am not payed to say it >D