Firefox update failure

On May 23, I received a software update notice that included updating Firefox. After agreeing to the update, Firefox will not run. It starts but it immediately goes to the updater which stops and closes the window.

I have tried removing and reinstalling Firefox through the Terminal and with the Ubuntu Software Center with no luck.

Hi @tomi,

change your software sources download location and re-install it again!:

I think I need to get rid of the updater. Reinstalling Firefox from a new download location did not work. Where is the updater stored?

When you update FireFox in terminal what errors do you get? Did you check for broken packages?

sudo apt -f install

check the install :> sudo apt-get update
sudo apt-get upgrade

I don't recommend doing this :thumbsdown: but here you go if you want to do it, I don't think it will solve anything for you though!:

sudo apt-get remove update-manager

I would try the following commands first!:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

No errors reported during update. Running Firefox from terminal resulted in errors but I cannot find the screenshot file.

OK. I will not get rid of update-manager. I had run the other two commands in terminal, reinstalled Firefox, and restarted 16.04 on my Mac ppc. No change.

Really need to see those errors.

Didn't realize this was a mac. I can only assume our methods will work on a mac.

Hi @anon42388993,

I didn't either, @tomi, please see the following link with links for troubleshooting PowerPC:

Nothing there. I am about ready to give up on Linux. Every time I finally solve one problem a new one pops up out of nowhere.

I don’t know the fix for your current FF, but maybe an older (supported) version of firefox would be a better choice for you. FF ESR

This has been discussed here

1 Like

I started that thread as a way to get anyone else who is having this issue to add their “this effects me too” on the Launchpad Bug site . . . it is linked in the forum thread . . . but it is #1583849 . . . . I tried the “-f install” routine as well . . . nada. According to one of the devs who replied to my bug “this effects all big-endian architectures” . . . seemingly only in 16.04.

Over in my LM side of my MBPro running 17.3/based on ubunut 14.04 . . . the upgrade on FF went through w/o the problems that showed up in 16 . . . FF just shows a hollow window “frame” and then shortly thereafter . . . crashes . . . . Back over in 10.5 partition.

I is clear that the problem lies with the recent Firefox update. Is anyone working on fixing this problem?


Things don’t always happen fast in linux, as many hands contribute to a project, finding the hand that made an “error” may take time. If this effects you please add your name to my bug report on LP, or there might be another one . . . that will definitely help things move “faster” than just one guy, or now two guys, complaining there.

Also, try another browser, on my PPC MATE install I don’t have so many choices and FF is the one with greatest function, but I have Qupzilla and Midori installed . . . both “work” with some “issues” . . . but possibly Chromium might be an option if you aren’t in PPC limitation world. Usually in linux there are “options” available . . . so, “no waiting.”

1 Like