FIX - Firefox "Smooth Scrolling" tearing + youtube video tearing


#1

Ok, just another annoying issue on Ubuntu Mate 18.04 make me investigate and found an easy fix, that might help others in this forum.

On Firefox I have a really annoying screen tear when scrolling, after Firefox introduce “Smooth Scrolling” couple of releases before. An I observe the same thing in Youtube video playback, and couple of days ago It start to … me and ask myself where is the problem?

The video card is Quadro 2000 is old, not very performance for this days, but is not … , and what the hack is a simple Youtube playback, or text scrolling in Firefox, for a video card that you can do professional CAD work for low-medium assemblies.

So with this learn myself what a screen tear means, vsync, g-sync, free sync,… install and test Chromium, check in Windows…until I open another one of my system with a worse card, a Quadro FX580 (witch I intend to replace) and somehow found that it work smoothly (same Ubuntu Mate), and said what the hack, how is this possible, older generation, and low entry video card work better …

OK - SO THE SOLUTION

Control Center -> MATE Tweak -> Windows and select “Marco (Compton GPU Compositor)” instead of Marco (Adaptive Compositor)" to solve this … so happy playing…

I don’t remember this issue on 16.04, and I just notice it with that smooth scrolling in Firefox witch is not for a long time introduced, so maybe this issue is present only on 18.04, I don’t know, I just investigate this in last 2-3 days, as this issue it get stuck in my eyes :smiley:


#2

Oh, My, God, I LOVE you.
I thought it was just me! & such an easy fix.
Thank you Mircea!


#3

Making the value of layers.acceleration.force-enabled to true in about:config solves the tearing issue. It’s easier.:slight_smile:


#4

I wish that was true for my old MacBook! It does make Firefox render some things faster, though. Compton does solve the tearing, but it causes other issues, so I prefer Marco (adaptive) most of the time…


#5

I’m using Marco (Compton GPU compositor) and changing that config solved the tearing problem on Firefox. :slight_smile:

Both Firefox and Chrome have posed some problems in this release. I’ve shifted to Chrome for some of these reasons. :confused:


#6

OK @elcste you are right, I discover that on some of the system this setting is as you say , bring issues

  • On my main system with Quadro 2000 (installed proprietary nvidia driver - WebGL frame rate is 4 times faster) I observe issue on running Caja (not tested with nouveau), sometime is fast, sometime loading a folder it take couple of seconds, and selecting with mouse sometime is slower or selecting something up or down from mouse position, bot on the other side the entire desktop is a little bit slow in a positive sense, everything run “smoother”.
  • On a intel on cpu video this setting can render sometime the entire PC unresponsive if using the browser so you can’t do anything couple of seconds because nothing works.

Changing mentioned setting on some other system with AMD video card or on intel cpu video there is no difference, or just different but same issue.

Using Cromium is better on system where I tested, as tearing on scrolling does not exist because no “smooth scrolling” on system with smooth scrolling mouse ,and youtube video the tearing is in same place somewhere on top of the screen, visible only if I switch to full screen playing.

I observe that on my main system switching back and forth from GPU to adaptive and back to GPU will solve the issue par example in Caja, so for now I use the GPU mode to further testing, to see if I can leave it as my main setting…


#7

Linux software works Ok no matter what system you use…
On Linux Desktop unfortunately things are not the same, different system different issues, different desktop environment, different … so the only perfect desktop for now remain Micosoft Windows :smiley: , but I prefer Mate :slight_smile:

And by the way testing video card performance under Linux with open source or proprietary driver I do it very quick with…

http://alteredqualia.com/three/examples/webgl_pasta.html


#8

Thanks for this. It will come in handy.

Does anyone else think that this would make a really cool screensaver? Or am I just hungry?


#9

On Linux Mint, the layers.acceleration.force-enabled property is by default false in Firefox, just like in UM, but no screen tearing happens there(I used to use LM when I started using Linux in general).

This varies from distro to distro, obviously due to the modifications that are done in Firefox.

Changing that property to true solves tearing, but it causes sudden freeze and halt in Firefox, which is worse and more frequent than in Chrome. I’ve always used Marco(Compton GPU Compositor), but it didn’t change or solve the issue.

I had to switch to Chrome for that.


#10

So, how i fixed the screen tearing on Nvidia proprietary driver:

Check if your V-sync is active:

sudo cat /sys/module/nvidia_drm/parameters/modeset If the output is Y then it is active, if N do the following:
create a new file

sudo nano /etc/modprobe.d/nvidia-drm-nomodeset.confand insert the line:

options nvidia-drm modeset=1

Then:

sudo update-initramfs -u

Then check again with:

sudo cat /sys/module/nvidia_drm/parameters/modeset

Have a nice day to all!