Fixing overscan Raspberry Pi


I've installed Ubuntu MATE 18.04.2-beta1 to my Raspberry Pi 3B+.

There are large black bars all around my display.

I've tried using raspi-config to correct this, it has no effect.

I've also tried xrandr. I'm not getting the output I see in most places, it lists "Screen 0" but does not show what display ports it's using - therefore I can't address the port to try:

xrandr --output HDMI-1 --set overscan on

(for example)

I also notice it's using an odd resolution on my 1920 X 1080 monitor: something like 1824 X 892 or something. I can't change this, in "Display" all options are greyed out.

How do I correct overscan on the Ubuntu MATE for Raspberry Pi?

Thank you.

I just installed ubuntu-mate on a Raspberry Pi 3 and have black bars around my display also. Currently, I have not figured out how to fix this issue.

A few days ago I did a fresh install of Raspbian for the same device on a different micro SD card. During its "first boot" setup dialogs there was an option that specifically addressed this issue. I looked for that option while clicking through the "first boot" screens on ubuntu-mate but it was not there.

Please post back to this thread if you find a solution. Thanks!

All Raspberry Pis need a config.txt file. The contents are described here:

MATE's version is slightly different, probably older than the current Buster config.txt in Raspbian, but it does have the "disable_overscan=1" line.

Uncomment this (delete the "#" in front of it) and that took care of it for me.

In Ubuntu MATE it's in system-boot and the section looks like this now:

## disable_overscan
##     Set to 1 to disable overscan
##     Disable overscan if your display has a black border of unused pixels
##     visible and your display can output without overscan
##     Value    Description
##     -------------------------------------------------------------------------
##     0        Overscan Enabled (Default)
##     1        Overscan Disabled

Some Raspberry Pi distros have a "raspi-config" program or some variant of it that starts on first boot and alters this file. Ubuntu MATE does not so you must do this manually.

I disabled overscan using raspi-config to resolve the issue