Flash Player stopped working in Firefox

This is something weird, Flash Player stopped working in Firefox in UM 18.04. It was working normally until I installed Chromium and installed Flash Player for Chromium, which I do not exactly remember how I did, it was just a copy and paste from a Google search.

In Firefox all seems to work as expected: when flash is detected it shows a clickable icon to activate flash, so I do and supposedly it will start playing. But then nothing happens, either it does nothing or it freezes the tab or the entire browser.

And the same web pages work just fine in Chromium. As well as in Firefox using an installation of Linux Mint MATE 18.3 I have on this laptop, based on 16.04.

This is the output of Firefox ran from the terminal when trying to rum Flash Player content:

[code]$ firefox

(firefox:5666): LIBDBUSMENU-GTK-CRITICAL **: 18:36:29.041: dbusmenu_menuitem_property_set_shortcut: assertion 'gtk_accelerator_valid(key, modifier)' failed
[Parent 5666, Gecko_IOThread] WARNING: pipe error (131): Connection reset by peer: file /build/firefox-ikZgcS/firefox-59.0.2+build1/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[fresh 5837] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 5837] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 5837] not implemented: PPB_BrokerTrusted;0.3
[fresh 5837] not implemented: PPB_AudioOutput(Dev);0.1
[fresh 5837] [PPB] {zilch} ppb_network_monitor_update_network_list

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

###!!! [Parent][MessageChannel] Error: (msgtype=0x59000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv[/code]

These are all the packages I have installed using the search term "flash" in Synaptics:

Already messed around a lot trying to get Flash Player to work again on Firefox but without any luck. How can I fix this?

edit: the issue remains with a clean profile; also remains in the latest Firefox beta 60.0b16.

Hi @pemartins,

there was an update for Adobe this morning, check your settings and run updates again, try using “Main Server” for your downloads!:


1 Like

Thank you for the help.

Unfortunately I had no luck, updated but still get the same error. :frowning:

Hi @pemartins,

try the following terminal command (Ctrl + Alt + t):

sudo apt install adobe-flashplugin

Log out and back in after doing so. :smiley:

1 Like

It said it was already installed; I used install --reinstall with no luck, purged it and installed again still no luck, purged again and installed also with suggested packages but no luck, flash player won’t play in Firefox. Always the same error:

[code]$ firefox
[Parent 22670, Gecko_IOThread] WARNING: pipe error (140): Connection reset by peer: file /build/firefox-hoiE9u/firefox-60.0~b16+build1/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
[fresh 22833] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 22833] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 22833] not implemented: PPB_BrokerTrusted;0.3
[fresh 22833] not implemented: PPB_AudioOutput(Dev);0.1
[fresh 22833] [PPB] {zilch} ppb_network_monitor_update_network_list

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

Try changing your software sources download location to Main server if you aren’t already using it and update again, see the guide above for more info!. :smiley:

1 Like

I have set main server for the downloads, I believe it was the default setting or if it wasn’t I must have changed it right after I fresh installed UM 18.04.

It looks like a long shot, but can it have something to do with this?: UM 18.04 always goes into emergency mode on boot

I would first suggest a fresh install in case you have something broken which might be easier to fix?, try the something else method if it applies to you? (On the newer installer, you can overwrite the system files and keep your data but I don't have a picture of the page sorry!). :smiley:

The older page looks like this:

1 Like

Strangely today for the first time in many boots I did not get the emergency mode message and the boot went just fine, so for now I won’t be doing a fresh install. It leaves me just with a couple of minor issues, one being this weird flash not working in Firefox (but works just fine in Chromium) and the other the pc microphone volume control missing on the volume panel indicator (Ubuntu MATE 18.04 missing microphone volume control in panel indicator) which already happened on a previous installation of a 18.04 beta. So no big deal, no major issues.

Thank you very much for the help.

1 Like

Try running the following terminal commands (Ctrl + Alt + t) which may help solve your problem(s):

sudo apt-get update && sudo apt-get dist-upgrade -f

And for broken or missing files:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

I hope it helps. :smiley:

Incidently, there is an update for FireFox today so try updating and see what happens with Flash after that. :smiley:

1 Like

Did it but still no luck. Nothing was installed, reinstalled or removed. :frowning:

Updated Firefox but no luck, even updated it to the latest beta but nothing, no flash and always the same error.

Okay, I would try removing Chromium browser and the other Flash Player you installed with that and install Google Chrome instead! (Google Chrome is in the software boutique!):

sudo apt remove chromium-browser browser-plugin-freshplayer-pepperflash

Firefox uses HTML player (or whatever its called). :smiley:

I hope it helps. :smiley:

1 Like

Ok the oddness reaches its peak because that worked! :smiley:

Adding to that command line I just did a

sudo apt autoremove

and then reinstalled flash

sudo apt install flashplugin-installer

Flash player worked right after and no more flash player errors.

Installed after Chrome for backup browser, tested Flash Player simultaneously on both browsers and all works well.
I have no idea what was going on since I tried a bunch of stuff installing and removing Flash Player in different ways but that’s old news now, what matters is that a solution was found.

Thank you very much for everything.

1 Like

Hi @pemartins,

I am glad you got it sorted. :thumbsup:

1 Like