UM 18.04 always goes into emergency mode on boot

Every time I boot UM 18.04 it goes into emergency mode and I have to press Ctrl+D to login normally. Here’s the message:

"You are in emergency mode. After logging in, type “journalctl -xb"to view system logs, “systemctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.
Press Enter for maintenance
(or press Control-D to continue)”

Here is a journalctl -xb report:

Here is the content of /etc/fstab, which in browsing I found it could be useful:

[code]# /etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda5 during installation

UUID=c8520f09-ccc5-445c-9191-e12008ae4bc8 / ext4 errors=remount-ro 0 1

/boot/efi was on /dev/sda1 during installation

UUID=9298-7296 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0[/code]

It literally happens every time I boot UM 18.04. How can I solve this?

mai 08 19:19:13 pemartins-X55U appmenu-mate[2238]: Failed to fetch xid: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interfac

this seems to be the issue. no idea …

1 Like

Any ideas on how this issue could be solved? I’m still getting this annoying error :frowning:

Browsing online some different solutions can be found but applying them without knowing the exact root of the problem would be like taking medicine for the wrong disease, most probably I would end up with two illnesses instead of one. :smiley:

I’d suggest sudo apt install ibus but not sure it will fix it.

1 Like

Thank you very much for the help. Unfortunately it did not solved it, again it loads emergency mode making me press Ctrl+D to continue to login. :frowning:

Here’s the journalctl -xb report with ibus installed:

If ibus is not helping let me know so I can uninstall it.

You need ibus … some suggestions … a fresh re-install, re-install without UEFI, try if 16.04 installs correctly. I looked for issues for ASUS X55U … the output of dmesg should tell you where errors occur.

1 Like

Thank you so much once again.

I’ll try to avoid a reinstall for now, the Ctrl+D issue on boot is annoying but aside from that I notice no major issues on usage. Here’s the output of dmesg:

I’m so sorry for being asking you to read the reports for me but I look at them and I understand nothing. I really tried to reach some conclusions by analyzing some lines and googling them but I practically achieved nothing.

This dmesg appears ok. wifi is active, your disk (sda, 500GB) has many (9) partitions and sda5 is your root partition. The parameter you pass during boot is acpi_backlight=video. Is this a dual/triple boot system?

You could remove the acpi_backlight=video parameter (sudo edit /etc/default/grub, then sudo update-grub) and reboot. Not sure if this might be the issue.

1 Like

Triple boot. Windows 10 if I remember correctly (I’m more of a Doors guy :D), Linux Mint Mate 18.3 and Ubuntu Mate 18.04.

I tried removing that parameter but that wasn’t it. I use that parameter so I can control the screen backlight with the fn keys, without it I cannot control the screen brightness.

Is there a chance that that emergency mode is somewhere set to always pop up? I’m saying this because I read online that most of emergency mode issues are derivative from things that keep the system from starting, in my case I only press Ctrl+D and it boots normally.
In the message nowhere says that there is an error or that it will try to boot, simply states that I’m in emergency mode and to type exit or Ctrl+D to just boot in regular mode:

You are in emergency mode. After logging in, type "journalctl -xb"to view system logs, "systemctl reboot" to reboot, "systemctl default" or "exit" to boot into default mode. Press Enter for maintenance (or press Control-D to continue)

@pavlos_kairis thank you very much for everything and now forget about this, I realized what was wrong and it was something I made.

Once the pc took more than a minute to shut down so I browsed some threads here at the forum and found a post telling how to shorten the off time; so I did and set it to 15 seconds. It was n. 4 in this thread.
Turns out that most probably each time I shut down the pc it was not enough time to complete the shutdown process, so naturally the emergency mode poops up. Already undone the process and was able to boot twice in a row normally, no emergency mode at all. It’s solved.

Adding to this just a question, if the pc takes too long to shutdown, which log should I check to see what is hanging the system?