Ubuntu MATE 16.04 LTS - Common Problems, Known Bugs, Workarounds

Common problems affecting Ubuntu MATE 16.04 LTS

Those problems also affect all Ubuntu 16.04 flavors (Xubuntu, Lubuntu, Standard Ubuntu, etc…)

Mate bug reports can be found at Launchpad and Github.

Note: this post is now a Wiki.

  • [#1] - gvfsd-smb Fix for this issue was released.

  • [#2] - nm-applet (Wi-Fi)

If your home router has a long, random password you might encounter a problem when trying to connect to your WiFi.

This is because of Bug #767321 : There is a 20 second silent timeout on password input.

Corresponding Launchpad Bug #1589535 : this is now fixed mitigated by a longer (120s) timeout in Yakkety and in Xenial.
(But note: you won’t get the fix in the release image until the third point release becomes available. (16.04.3 LTS) so this will still affect you until you do the first update post-install)

An easy workaround is as follow:

  • Write the password in a text file (.txt, not an office document) on your Desktop.
  • Copy and paste this password from the text file into the dialog input box.

  • [#3] - intel_idle.max_cstate=1 (Complete freeze on cheap computers based on Intel BayTrail processors)

If you’re installing Ubuntu on a cheap computer platform using Intel BayTrail processor, you’re likely to run into this nasty problem: complete freeze more or less random (likely to happen when watching videos)

This is due to the horrible Bug #109051.

Despite this bug having been reported a while ago, it’s still not fixed.
Silver lining though: at least people are working on it.

The only workaround is to turn off CPU power saving modes using the following procedure:

Open a terminal using (CTRL+ALT+T) then type in:

gksudo pluma /etc/default/grub

Enter your password, and it will open the text editor. Change the line:



GRUB_CMDLINE_LINUX_DEFAULT=“intel_idle.max_cstate=1 quiet splash”

Save the file, close the editor, then update the bootloader:

sudo update-grub

… and reboot.

Also see post #12

  • [#4] - systemd (Computer takes a lot of time to power off)

Because of a design decision in systemd, the computer can take up to 90 seconds to power off.
If you’re anything like me this will slowly eat your soul (Only Windows is supposed to take forever to shutdown)

We asked the systemd maintainer if it was possible to change this default 90s timeout, but sadly such a change wouldn’t qualify for an SRU (Stable Realease Update) and therefore won’t happen in Xenial.

If you consider that this is too long and that nothing will break on your system (that’s likely the case if you have a reasonably fast drive - the time to flush I/O buffer to disk is not that long) you can manually specify a shorter timeout.

gksudo pluma /etc/systemd/system.conf

Find the following commented lines:


Uncomment the lines, change the timeout values and add one line so you end up with the following:


This should be a safe default. Depending on your hard drive speed you can reduce further. (I’m rocking 6s on a system with a SSD)

  • [#5] - Bash (Can’t set $TERM to screen-256color on tmux or screen)

To function properly, tmux and screen require that the $TERM variable be set to screen-256color. However, even when properly configured these two programs will always set it to xterm-256color.

This happens because the default .bashrc file is blindly setting that variable. When tmux or screen open a new pane, they set the variable to screen-256color as instructed by their configuration file. But when you open a new pane, you also start a new shell. So .bashrc will be called to set the shell environment and it eventually overrides $TERM.

To fix this you just need to open your ~/.bashrc file and look for the following line:

export TERM=xterm-256color

and replace it with the following:

if [ "$TERM" != screen-256color ]; then
    export TERM=xterm-256color

When a new shell is opened, if the $TERM variable is already set to screen-256color, it won’t change it anymore.

  • [#6] - Minimized Chrome Browser Kills Desktop When Running Compiz

See here:

- **[#7] Tor browser can no longer start after update**

See here:

  • [#8] Printers / Scanners connected via USB randomly disconnect / won’t work

Ubuntu MATE 16.04 TLS ships with TLP enabled by default. TLP is a program to reduce power usage of your device, but power saving of USB devices has been known to cause problem with printers and scanners.

For a workaround, see here:


@ouroumov Thanks for this informative post. I suggest slightly amending the section about systemd to inform folks more clearly that the default installation of /etc/systemd/system.conf has all the entries in the [Manager] section commented out


1 Like

Thanks @pfeiffep , I’ve just edited the post.
While I’m at it, I’d like to mention that I’ve made the post into a Wiki so if you have further improvements you should be able to edit it yourself.

That goes for every other community member with trust level 1. :D

1 Like

Great post! It has been bugging me that it takes so long to shut down since with the SSD I can start up in about 11-12 seconds.

Great work @ouroumov !!!

I ran 15s on standard HHD without issue.

My Dell laptop has the entire manager section commented out - it shuts down in 10 - 15 seconds.

@motivation here you can post workarounds for bug’s if you whant to report a bug go here https://launchpad.net/ubuntu-mate

1 Like

Added information on:
Bash (Can’t set $TERM to screen-256color on tmux or screen)

1 Like

For #3 this is a better fix that worked for me.

1 Like

A post was split to a new topic: Install issue: Ubuntu Mate 16.04 x64 on an Acer Aspire E5 573