Focal RPi4 image no Youtube video on Firefox


I installed the new Raspberry PI image of Focal but I am not getting youtube videos on Firefox (nor Chromium). The video starts buffering and then a message appear on top of the video that says: "If playback doesn't begin shortly, try restarting your device."

I should say that I have another RPI4 installation using the method of using rpi-imager + desktopify + dedoimedo approach and it works perfectly. Maybe its a bug?

Also maybe unrelated but each time I boot this image I get a Submit an Error Report window just after desktop shows completely.

Today I updated my "other" RPI4 and after the updates were applied now I dont have video here either. bummer. The same thing happens with Firefox and Chromium:



Same thing here: no video playback in youtube in both chromium & firefox. Not in Ubuntu Mate 20 LTS and not in Ubuntu Server with xdesktop installed.

I have tried 64 bit Kali for RBP4: video playback works in both Firefox and Chrome.

Anybody aware of a fix for this in Ubuntu??


todays upgrade has fixed youtube playback!!

1 Like

:slight_smile: SOLVED!!!

Sorry to inform that the reason it wasnt playing, in my case, was because of something trivial and not really trivial :confused: :thinking:

It turns out that issue happens when the output device for the sound is left by default on a Raspberry Pi 4 which is the headphones output, instead of any of the two HDMI outputs.

For brevity of this post please see this other post for the details: