Galculator application not working properly

First and foremost I apologise to ask such a silly question, but however.
Dear all, my Galculator application on 14.04.2 is not working with ‘%’ percentage. Trying to reinstall the app seems like a daunting task according to ‘Ubuntu Software Centre’. Is it a bug? Whether it is safe to use ‘Synaptic’. Any help is much appreciated.

Hi @S_A_Patil How is it not working correctly?

For instance, if you hit 20 then the Percent key, then 100, then the Enter key… what happens?


search for the app in Synaptic and right click it and then select it for a re-install (Mark for Reinstallation), also whilst you are there, when you right click the package again, see if there are any suggested or recommended packages you can also install to enhance the apps productivity!.

As an example:

Hope it helps. :smiley:

My dear electragician, thanks for the prompt reply. The result is 20 that means it is calculating ‘%’ properly, but however if I do 100,+,20,% it is not giving any answer but of course an error sound. By this I can say it is finding percentage but not adding or subtracting the percentage to the result.
My dear wolfman, thanks for the suggestion. I followed your instruction but in vain.
I raised this question because basically I was achieving the addition and subtraction of the percentage in 14.04.1, but, not now???


do you have it in the right mode?, click on "View" and change the mode:

My dear wolfman, thanks again for the kind reply. Yes I combed the whole app but in vain. I faced the same problem in SpeedCrunch. In Windows 7 if you do “value, +, %, =” you will get ‘result’ but the same doesn’t happen in Galculator, you have to do “value, %, =” and then math the result to the value. For proper understanding I have given instance.

Windows 7:


I hope I’m clear.
Thanks in advance.

Hi S_A_Patil,

I tried it with your sums and it doesn't work for me either so I assume its faulty, you can install "gnome calculator", just open a terminal and paste the following command (Ctrl + Alt + t) (Or use Synaptic!):

sudo apt-get install gnome-calculator

That one works as I just tried it!:

You'll find it in Applications > Accessories once installed!. :smiley:

My dear friend thank you very much for your guidance, it worked perfectly for me. See you again my friend :relaxed:

1 Like

Hi S_A_Patil,

glad it worked for you, please take the time and edit the topic title so it shows the word “(SOLVED)” so this will help other Linux users!. :smiley:

So it looks like this: (SOLVED) Galculator application not working properly

Thanks. :smiley:

(We really need a “(SOLVED)” button Wimpy!). :smiley:

1 Like