Generic OS goofinesses...and queries thereby

I helped a friend to move into slightly newer h/w & Ubuntu Mate 18.04 with success...mostly.

He has a terrific, older HP laser printer that was always recognized & has always worked perfectly;
Until that day when I connected his renewed desktop PC to it, then...nuttin !!

I tried every trick I knew, searched & poked & prodded until=>
A post someplace mentioned that generally the parallel ports had been deprecated (or the like) since some prior version - and no amount of searching brought me any method to un-deprecate this.
Major bummer, as I live 1 1/2 hours from his house & had no other cables with me.

Later, he had time to dig through his stuff - found a USB device cable - connected it, and BANG - instantly he had a working printer.

My 2 cents on this situation: IT STINKS.

My 2 part query now:
1 - WHY was that 'deprecation' done - please don't tell me that cybercriminals attack via the parallel ports - I am NOT that gullible ?!?
2 - How to un-deprecate the parallel ports now AND moving forward in time, as I too have a very good laser printer still in use that does not have USB ?!?

Another unrelated goofiness:
I was blessed to be able to get a very nice HP notebook a while ago & Ubuntu Mate 18.04 was a pleasure to get into that instead of the abortion called '10' - BUT=>
Inoperative internal wifi.

I'd been through this before with a friend's identical notebook - but searched some more anyhow just for the halibut...with no useful result.

Not a huge deal as pluging in the ethernet cable solved it for that time & it updated beautifully.

Later I just ate up a USB port by sticking in a known to work USB dongle & it came to life instantly.

No biggie in total - except that this is a portable device and it SHOULD basically do whatever it takes during setup to properly configure wifi as that other (nasty) OS family does....but it does not and this is NOT the 1st time or model I've seen this happen with.

My ultimate question about this h/w category:
Are there just too doggone many wifi adapters or the like - is this why this particular goofiness happens so routinely ?!?

OK, I've got to move on right now to other things - but I needed to put this outthere in case there may actually exist better ways to deal with such goofinesses.

Thanks for reading my ranty query !!

Parallel port depreciated?

That is news to me:) HPLIP still shows Parallel Port as an option. I have ancient parallel port printers working.

Also -- from dmesg:

parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
lp0: using parport0 (interrupt-driven).


Wifi not working - Working wifi in Linux requires some help from the chip vendors. It is just not possible to write an open source linux driver for secret hardware.

djb

1 Like

Are you not resigned yourself to that kind of occasions yet?
(A deep sigh)
I can not still forgive manufacturers for 16:9 LCD form factor and its glossy coating!
(Another deep sigh)