Get rid of "Unlock Keyring Authorization required" modal dialog on Ubuntu-Mate 20.04 autologin

I'm re-purposing my old development laptop, but would like to save time by avoiding a complete reinstall (which didn't go smoothly initially), the key issue is that it needs to boot and run my graphics mode code automatically. But this laptop has an issue that seems to prevent unattended restarts.

After the auto login, a modal dialog pops up that prevents any user interaction:
"Unlock Keyring" Authorization required.

How do I get rid of this? or figure out what is automatically starting that is causing it?

I've unchecked the three "GNOME keyring" services in "Startup Applications Preferences" but it made no difference, they are still unchecked once I type in the password to unlock the keyring. I've also unchecked the "Evolution Calendar Notification" to no avail. I also have "automatically remember running applications" unchecked in the start up options.

Any idea as to what is causing this need to unlock the keyring? or how to stop it?

I have two other 20.04 Mate systems and they don't pop this up until I open Chrome browser. And I do have remember running applications checked one of these, and still don't have this issue if Chrome is not one of the running apps.

Hi, @wally333 ,

this article may be helpful:

Try installing seahorse and inspecting your login keyring in ~/.local/share/keyrings. Its contents may give you a clue to a service responsible for these unlock attempts.
I have a recently installed UMATE 23.04 test system, its login keyring is empty, and I observe no authorization requests on autologin.

Hope this helps.


The article would be useful but it doesn't help me figure out what is broken here. When I open "Passwords and Keys" it shows this:

So I can't reset the password.

That's just a gpg key section. Try resizing your window, and you'll see the entire key storage eventually.


1 Like

Resizing the window let me see the sidebar menu, The more Gnome3 invades mate the worse it gets.

I've done the change password twice, each time it gave me the warning when I set the empty password, but it still pops up the unlock keyring modal dialog when I reboot.

Any other suggestions? I really need this to go away before I can proceed with turning this system into an "appliance".

1 Like

I don't know if this will work for you, this was for Chrome but has worked for me on every time I installed Chrome and this happened.

Open a terminal and enter:
rm ~/.local/share/keyrings/*

Now open Chrome, if it asks you for your password, do not enter one choose Continue each time and ignore any warnings.

Try running the command and then when it asks for your password for the login application, choose continue each time and ignore warnings. Again I don't know if this will work for your issue and have not tried it.
Warning: It could cause you more problems, but you have little to lose right now.


Does this dialog accept your new empty password or an old one?

This will effectively reset all user keyrings by REMOVING them. I'd make a backup of keyring folder before doing this to be able to restore them later. We still don't know whether @wally333's keyrings are empty or contain anything valuable. Worth trying though.

1 Like

It doesn't wait for me to launch Chrome, it pops up as soon as the autologin is complete and is a modal dialog so no other UI stuff works until it is dismissed.

Thanks I created ~/.local/share/keyrings.backup and moved everything that was in keyrings into it. When I rebooted the unlock keyring dialog did not pop up.

Before I did this, after the failed attempts to remove the password from the keyring it required my original password, obviously it wasn't being changed.

In its new role as an appliance it will not be surfing the web of logging into other systems so there really aren't any passwords to be saved.

As a test I opened a SAMBA share on another machine and choose "save password forever and it put up the keyring dialog which I dismissed by setting no password.

When I rebooted there was no dialog popped up and when I connected to the remote SAMBA share without asking for a password. A new default and Default_keyring.keyring was created which as expected had my SAMBA share password stored as plain text.

I'll play around with it some more, by trying to now set a password (equal to my login password) on the keyring with "Passwords and Keys".

In general I'd rather not have what passwords are saved on the system be in plaintext, but for the appliance application I can delete the keyrings if it doesn't act like my other systems and only popup the unlock dialog the first time something actually needs to unlock it since it normally won't be connecting to anything.


You are welcome @wally333 !

I hope the problem will not raise again with your appliance system. Thanks @jymm for the idea.

I can only imagine a situation, when the system used several different keyrings. While you removed the password from your login keyring, some service tried to unlock another (locked) keyring on bootup. I have no other ideas.


This is very informative. Thank you

1 Like

Welcome @jerry001 to the community!