GNOME Software Centre for 16.04 is ready for testing

I came across the article from OMG Ubuntu! that the GNOME Software Centre is now ready for testing in 16.04 Xenial Xerus.

For those unaware, regular Ubuntu will be replacing the ever-aging Ubuntu Software Centre (USC) with GNOME Software Centre. Ubuntu MATE 15.10 doesn't ship with any and gives you this choice in Welcome.

If it is fully compatible, this will ship by default in Ubuntu MATE 16.04 LTS. Welcome will continue to offer alternates.

If you fancy giving it a test run, here's the PPA:

sudo add-apt-repository ppa:ubuntu-desktop/gnome-software
sudo apt-get update && sudo apt-get install gnome-software

:bug: At this time of writing:

Once installed you’ll need to run this script as root to fetch and populate the app with AppStream data (as of writing, applications still won’t show up. This is a known issue and will be fixed in a later update).

1 Like

when I ran update I got an error:

W: Failed to fetch 404 Not Found

W: Failed to fetch 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I am using Ubuntu Studio 14.04 LTS with Ubuntu Mate over the top

Should have mentioned, this is for 16.04 only. I’m not aware if there’s plans to backport it to 14.04.

1 Like

No worries, I am a synaptic and terminal man myself…:slight_smile:

1 Like

Hi guys :slightly_smiling:

Also a synaptic user, but curious about this package. Think I’ll wait for the fix to come out before giving it a spin.

Thanks for the heads up.

Just done a complete fresh install of 16.04 and will try it out a tad later!. :smiley:


Hi Luke,

I installed the GSC but I think I am having a problem with your script, am I supposed to make it executable?. :smiley:

I don't know for sure, I only shared the news and had a quick test. (It's not my script either!)

One of the comments from the article suggests this:

Before running the script in the article you may want to install appstream:
sudo apt-get install appstream

A reply reads:

I've read elsewhere that you should run that : sudo apt-get install packagekit
The same?

Maybe installing one of those is what's needed to fully run the script?

1 Like

Thanks @lah7,

okay, I made it executable and then run it as root in a terminal Alt + F2 > gksudo caja > double click on the downloaded package > "Run in terminal", to run it; open a terminal and type "sudo gnome-software" or "gnome-software" (you will have to enter your password after selecting a package if you use the 2nd command!) and you get this:

I used the first command you posted (appstream), packagekit was already installed!. :smiley:

Right click the downloaded package > Properties > Permissions > Allow executing file as program:

Now to try it out!. :smiley:

I tried it out and it is broken!, it won’t install anything and barely any packages are showing!. :confused:

Currently, I think it’s only showing installed packages, but it’ll give a feel of what could be the next default software centre for now.

To me, too GNOME 3-like :frowning: , doesn’t fit with the rest of the system, but no surprise!

1 Like

I’ll just add to the list of “Broken Ubuntu things”!. :confused:

GSC updated but it is still broken, it isn’t showing anything in the lists!. :confused: