Gparted not launching

I want to run gparted to format a usb flash drive. When I run it I see the bottom panel showing “Starting GParted”. After a few moments it disappears and nothing else happens.

When I run gparted via terminal, here is what I get:

Created symlink /run/systemd/system/-.mount → /dev/null.
Created symlink /run/systemd/system/boot-efi.mount → /dev/null.
Created symlink /run/systemd/system/run-user-1002.mount → /dev/null.
Created symlink /run/systemd/system/tmp.mount → /dev/null.
/usr/sbin/gpartedbin: error while loading shared libraries: cannot open shared object file: No such file or directory
Removed /run/systemd/system/-.mount.
Removed /run/systemd/system/boot-efi.mount.
Removed /run/systemd/system/run-user-1002.mount.
Removed /run/systemd/system/tmp.mount.

Any ideas how to fix this?

P.S. I’m on 16.10

Do you have gtkmm packages installed ? try this

 LD_PRELOAD="here you write path to gtkmm library" gedit

you can get the path of the file from synaptic from gtkmm package

Is this a live install?

Nope. I am running 16.10 installed on my hard drive. It was working fine a couple of weeks ago, though.

I don’t seem to have installed. However I tried “ls in usr/lib/x86_64-linux-gnu/” and got

i’m not sure what to do next.

Okay, what fixed the issue for me is re-installing libgtkmm-2.4-1v5 via synaptic.

Thanks for your inputs @IvCHo and @anon42388993

Gparted launches now :slight_smile: