Grub boot menu shows Windows 10 Loader on Ubuntu mate none dual boot

Hi, i’ve been using UM (Excellent OS) for a few months now which was a clean install onto my Toshiba C660 laptop about 5/6 yrs old, i3, 8gb ram, 500gb hybrid drive, and after a couple of initial problems i managed to get it running fine & today i installed some updates using Software Updater but after a restart i started getting the Grub Boot Menu showing up & 1 of the options is Windows 10 (Loader) which i don’t understand considering the only OS installed is UM & no dual boot. I have tried hiding grub using Pluma etc/default/grub but the 2 listings are already set at: GRUB_HIDDEN_TIMEOUT=0 & _QUIET=TRUE, so i installed Grub-Customizer & unchecked both Show Menu & Look for another Operating System, this seems to have worked for now but can anyone suggest an alternative fix or why it happened.

Your help would be appreciated, cheers.

Hi @davson723,

did you fully format the HDD before installation or did you leave MBR still intact?. Did you select a different location for Grub different to dev/sda/?. :smiley:

1 Like

Hi wolfman,

Thanks for your reply, i deleted all partitions till i had unallocated space on the HDD & assigned new partition & “Letter” followed by format in Disk Management & i allowed the default installation of UM which i believe carries out another format.

From the sounds of a format from within Windows’ Disk Management, there’s still an OEM, a hidden, or a recovery partition.

Boot up a live CD/USB and open GParted from System → Administration. A completely clean default install would only have a partition for Ubuntu MATE and the other as swap.

If you find any NTFS or FAT32 partitions, you can delete them. When you next boot Ubuntu MATE, run this command to update the boot loader entries:

sudo update-grub

If there isn’t any leftovers, this would be very strange indeed.

Hi lah7,

thanks for replying, could you please clarify what you mean by “Boot up a live CD/USB” etc, are you referring to the Ubuntu Mate USB i used to install the OS.

Opening GParted on my installation it shows:
/dev/sda1 Ext4 / 446.26 GiB
/dev/sda2 extended 19.49 GiB
/dev/sda5 linux-swap 7.80 GiB
unallocated unallocated 11.70 GiB
unallocated unallocated 4.52 MiB

sda5 & unallocated 11.70 GiB close into sda2 which i assume forms that partition.
unallocated 4.52 MiB does not & stands alone.


Yep, I did mean the Ubuntu MATE live session, but it’s OK as you have GParted already installed.

That’s very odd, as your disk doesn’t give a clue for any traces. :confused:

To help identify what could be causing it, what does the entry say?

Windows 10 (Loader) on /dev/xxx

An extended partition is just a container for logical partitions. If you like, you can re-shuffle the partitions to re-claim your unallocated space, this should be done in a live session.

**Here's how to do it in GParted**
  1. Delete linux-swap (/dev/sda5)

  2. Delete extended (/dev/sda2)

  3. Apply

  4. Resize (grow) / but leave 7987 MiB at the end.

  5. Apply

  6. Create a new linux-swap partition using the remaining space (7.8 GiB)

  7. Right click that swap partition and go to Information – copy the UUID.

  8. In the terminal:

     sudo mount /dev/sda1 /mnt
     sudo pluma /mnt/etc/fstab
  9. Where it reads “swap”, erase the old UUID and paste the new one, then save.

  10. Swap sorted, disks resized, ready to reboot!

Hi, sorry did not reply sooner only it was midnight in my part of the world, anyway the entry say’s:

Windows 10 (Loader) (on /dev/sdb1)

as you said “odd” because there isn’t an /dev/sdb1 showing up in gparted.

I did a google search on how to re-claim the unallocated space on the HDD but did not get round to doing it. Your instructions seem to be a lot clearer so will try asap. thanks for that.

You’re welcome, let me know if you ran into problems. :slight_smile:

Now about this mysterous /dev/sdb1 drive… Were there any flash drives, external hard disks or memory cards plugged in when GRUB updated?

We could take a look with this command of if it’s still there now:

sudo fdisk -l

(Paste and link using Pastebin)

Otherwise, if /dev/sdb is nowhere to be seen, it should be good to update GRUB again:

sudo update-grub

My bet is that Windows 10 has been infesting it’s bootloader on other connected drives which may have been plugged in when the kernel updated.

1 Like

Just to make something quite clear, make sure you don’t have any USB sticks plugged in to the PC when you update Grub!. :smiley:

The chances are that the Windows bootloader is somewhere on your USB stick and as @lah7 pointed out, it may well be festering there!. :smiley:

OK, Your absolutely right, when i was using Windows on this laptop i swapped out the CD/DVD drive for a 2nd Hdd caddy which i had configured for storage Downloads, Documents, Pictures etc, but when i chopped over to UM i was unable to configure it so the only way i use it is by mounting it when needed which was working fine until the other day when i installed updates on UM & that caused the Grub boot menu to start appearing, i didn’t consider it was the caddy HDD as it was unmounted. Solved.

Also i followed you instructions regarding the unallocated space & it worked a treat. now i have /dev/sda1 for / & /dev/sda2 for Swap.

Thank you very much for you time & help & if you have any ideas on how to configure that 2nd HDD for storage in UM i very much like to hear them. Cheers again

1 Like

Yeah you’re right wolfman it was a 2nd HDD i had installed that i didn’t consider as it was unmounted & thought it could not cause problems,

Cheers for your help.

1 Like

No problem. :slight_smile:

As for the culprit…

If the disk is empty, you can wipe the whole drive in GParted by going to DeviceCreate Partition Table. This clears everything – partitions and the boot loader, like a fresh drive.

Otherwise, if you don’t want to wipe that disk, one trick is to install GRUB’s bootloader in place of the Windows remains… that’ll prevent this from happening in future: :wink:

sudo grub-install /dev/sdb

For making the second drive a dedicated data drive…

The easiest method would have been to use the “Something else” option when installing to make the second drive the /home mount point. Personal files are stored there.

Now it’s after installation, we’d have to do this manually. There’s a few ways to do this, and may involve editing /etc/fstab. I do it a bit differently:

1 Like

Excellent, if i have to do a fresh install i’ll use the “SOMETHING ELSE” option, when i get some time i’ll transfer my data too /dev/sda1 & use gparted to create partition table but for the moment i’ve gone with using Gnome Disks fstab entry option, that seems to work.

Once again thanks very much for your time & help.