Grub menu remains hidden in 20.04

I'm pleased with UM 20.04 and it's all fine here except a weird annoying GRUB menu bug I'm hitting:

Basically, GRUB menu remains hidden regardless of any GRUB_TIMEOUT and GRUB_TIMEOUT_STYLE settings, which don't apply (obviously I'm running update-grub each time).

Thing is that at boot I CAN navigate through menu items, since they ARE actually there and the system starts up accordingly, but they won't just show up no matter what keys you press or what you do: the screen stays black and I have to navigate blindly through the menu!

Try with grub customizer

Settings are ok and work with other distros (grub 2.02 and Debian, grub 2.04 and Void), it won't help.
Problem here is that settings are not respected and changes directly applied to grub.cfg will get overwritten eventually.

By the way, on my desktop pc with BIOS/MBR setup and grub-pc it works as it should.
On my EFI laptop it just doesn't: I can use cursor keys and blindly select items but the menu itself is invisible and the screen freezes on "Starting grubx64.efi
"Using load options ' ' ".
Secure Boot is not supported by the laptop and all the grub-efi-amd64-signed and shim* are therefore removed.

As a possible workaround you could try adding a line like this in etc/default/grub -


to get something similar to this which works for me.

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

Thanks, I just tried this but it doesn't change anything.

Perhaps adding the line below might help.


Already tried that, the menu still won't show up...

I manually installed grub-efi 2.02 from bionic and it works as intended: grub-efi 2.04 is clearly broken.

EDIT: Here also GRUB (efi) packages from eoan and disco are broken and don't show the boot menu.
The last working one is from Bionic and I'm sticking to this version for a while.

EDIT 2: @mdooley grub-efi version 2.04-5 installed from Debian archives does not have this issue.

A very good tutorial on grub customer.

My grub screen:

See if this bug below is what you are experiencing. Please add appropriate commentary to that bug report.

Yes, it's exactly that. Done!

I added my issues to this bug that I experienced recently in both Lu & U-MATE 20.04 where an apt upgrade of various grub packages seemed to wipe out grub and only write the ubuntu option for booting, rather than the other four OSs that are installed.

First and only time I had a "GUI" window open from a console upgrade asking, "Where is grub supposed to go?" And then seemingly overwrite grub with ubuntu . . . had the problem happen in Lu 20, fixed it, then had it happen again in U-MATE 20 after that. Time consuming to have to "fix" . . . .