GRUB prompt on boot

installation
system

#1

This is my first post in this amazing community (but I’ve been using Linux for 9 yrs now), and I am so excited to see your smiling faces!

Background:

I have been running Ubuntu MATE without any problems on this very laptop for a little over a year now. I originally installed 16.04 LTS and then later this year upgraded to 18.04 LTS, without any problems. Everything was working great!

Issue:

It all started, when I decided to upgrade the HDD in my Lenovo V570 with a SSD. Every-time I boot my computer, I go to GRUB prompt. Even when I manually chose to boot from my SSD. But to my luck, I stumbled upon this post - except in my case, I was not seeing grub rescue prompt, but grub prompt instead.

So now, I always have to run following commands on GRUB prompt, every single time I boot my computer, but at-least I am making some progress! (What progress? A post explaining what was happening before I deleted MBR, and why I had to do it. )

grub> root=(hd0,gpt2)
grub> configfile /boot/grub/grub.cf

After booting into my system, I did this, but the issue still persists:

[email protected]:~$ sudo grub-install /dev/sda
[sudo] password for me: 
Installing for x86_64-efi platform.
Installation finished. No error reported.

[email protected]:~$ sudo update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.15.0-23-generic
Found initrd image: /boot/initrd.img-4.15.0-23-generic
Found linux image: /boot/vmlinuz-4.15.0-20-generic
Found initrd image: /boot/initrd.img-4.15.0-20-generic
done
[email protected]:~$

More details:

https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/grub-mbr-and-ssd-upgrade-4175633671/#post5877577

Ping back: Ask Ubuntu Stack Exchange post


#2

I could be way off here, but it sounds to me that during your original install, the bootloader somehow got installed on the thumb drive and all the attempts to fix it were complicated by the UEFI bios.

My suggestion, FWIW:

  1. Enter bios and follow whatever convoluted process is necessary to switch to legacy mode (my wife’s G50 was a nightmare).
  2. Boot from a LiveISO and back up whatever you need to.
  3. Open GParted and delete ALL partitions.
  4. Reboot the LiveISO and install as usual – paying special attention to where the bootloader will be installed to, changing if necessary.
  5. Reinstall any other applications and restore your data.

Over the years, I developed the attitude that it’s often easier and more effective to just cut your losses and start all over. Also, I’ve found that - for me, anyway - whatever dubious advantages that UEFI has is offset by the added layers of complexity. YMMV.

Good luck.


#3

An accidental GRUB2 upgrade with default /etc/default/grub file, fixed this issue after a reboot. [Details]