Gtk-Message: Failed to load module "topmenu-gtk-module"

When I run Pluma from a terminal, I get "Gtk-Message: Failed to load module “topmenu-gtk-module” and then Pluma opens as normal.

It possibly does it with other applications as well.

Does anyone have any idea why?

If you’re on 15.10 you can safely ignore that warning :slight_smile:

I am on 15.10, though not for much longer :slight_smile:

I just don’t recall seeing it before.

Try changing your software sources download location Steve and do a new update, it might help?. :smiley:

1 Like

Thanks for this @wolfman

1 Like

I had the same problem running gvim after I upgraded from 14.04 to 16.04. It didn’t seem to do anything bad, but I always hate to see error messages so I looked around a bit. I found by looking in synaptic that topmenu-gtk was not installed. After I installed it, the error went away.



I encountered this error message, Gtk-Message: Failed to load module "topmenu-gtk-module", while trying to run tuxboot 0.8ppa2~xenial on Ubuntu 16.04.03. I added topmenu-gtk-common, topmenu-gtk2, and topmenu-gtk3. That cleared the error message, but did not fix the problem with tuxboot.

I solved this simply re-installing $application (in my case, Firefox)

After upgrading from Ubuntu MATE 16.04 to 18.04 I am seeing this error message while starting virtually every GUI program (e.g. caja, mate-terminal, mate-calc, pluma, gvim, soffice, google-chrome, firefox).

I also see the error recorded in syslog:

$ grep "topmenu-gtk-module" /var/log/syslog
Sep  1 10:25:38 mypc wnck-applet[2662]: Failed to load module "topmenu-gtk-module"
Sep  1 10:25:38 mypc notification-ar[2676]: Failed to load module "topmenu-gtk-module"
Sep  1 10:25:38 mypc mate-indicator-[2674]: Failed to load module "topmenu-gtk-module"
Sep  1 10:25:38 mypc clock-applet[2675]: Failed to load module "topmenu-gtk-module"
Sep  1 10:25:38 mypc mate-drivemount[2684]: Failed to load module "topmenu-gtk-module"
Sep  1 10:25:38 mypc /usr/bin/python[2663]: Failed to load module "topmenu-gtk-module"
Sep  1 11:26:45 mypc mate-notificati[11945]: Failed to load module "topmenu-gtk-module"

On I see that topmenu-gtk packages are not available for bionic.

So, how to fix this issue on 18.04?

Upgrading sometimes breaks things. Please look at this bug report and see if there is something in there that you might use to resolve your issue -

Good luck @rpr .

Edit: Also see -

I join this topic: I use Mate as DE for my Ubuntu Bionic.

I removed, my choice, the topmenu, and all applications work fine except for this annoying warning, as well as the warning about the system complaining about the impossibility to update the recently used file list (other modification made because, apparently, is the only way to stop that function).

I know that the “solution” for the problem is to reinstall and/or reactivate something that is not good for me. (I don’t want to discuss about why these are necessary/wanted/unwanted/annoying. this is my work requirement and my taste. I know that what’s not good for me can be good for others)

Is there any way to make GTK stop complaining about this?

I mean, I know that the function is not available. I removed it.
I don’t want to receive this message every time I call a GTK application.

With Wine I can silence some particular classes of warnings by setting an environment variable (and it has a lot).
Has GTK something similar? An environment variable to say “Ok, I already know about that, don’t bother me anymore and concentrate on the real warnings”

Thanks in advance

Fixed this by editing /etc/X11/Xsession.d/99mate-environment, here were some lines along


remove the :topmenu-gtk-module in all occurencies, reload gdm3/lightdm/whatever or just restart.


Dmitry, thank you for that advice. It fixed the issue on Ubuntu MATE 18.04.

Sorry for the delay, dmitry.
It works like a charm. :+1::+1:

Thank you very much

It seems that the correct fix for this problem is to simply remove the file /etc/X11/Xsession.d/99mate-environment altogether. It’s been replaced in 18.04 with 80mate-environment, which should also be present in the same directory and 99mate-environment should have been removed in the upgrade. Look at the file dates on these two files and you’ll see that the former dates from 2016, while the latter replacement file dates from 2018. See Problems with the dropbox icon in the panel (UM 18.04.1) - Look down the page a way for the comment on this by Norbert_X, Aug. 18. This solution worked for me.

I expect that this is a bug in the upgrade process.

1 Like