Guidance desired: Any/all printing brought 'an error occurred while printing', and then

And didn't - for no apparent reason - I think ??

Before making this post I searched here in hopes of any simplified guide as well as generally and visited this as well:

The main problem for me was when trying to print in any form from a web page, like the receipt I needed a paper copy of yesterday - but all I got was the dialogue box saying 'an error occurred while printing'.
I had to go & pick up that order - minus any receipt - so I left it that way.

Came back to it today & got the same error message, so I looked through - the logs there, but the volume of info is way beyond my knowledge level.

All had been fine with both PDF 'printing' & my Brother HL-5050 on USB for a very long time, and then making PDFs gave that error, and after a while it was all I got, even when trying to request a print preview...but just now I went further & tried printing from Nomacs - which worked for both, then from Leafpad - which also worked - and finally back to that receipt in the browser & that worked both ways as well.

I hope this never becomes a problem again - but if/when it may - is there any really clear & maybe simplified guide that goes sort of step by step to help in tracking down & recovering from a vague printing error like what I got ??

Thanks for any guidance in this matter.

Hallo computerguy

My advice is to upgrade to 20.04, or perhaps wait a little and upgrade to 22.04. If I had your problem I would back up my data and do a fresh installation rather than upgrade the 18.04 to 20.04/22.04.
Remember to back up your data before you try to upgrade. Good luck. :slightly_smiling_face:

1 Like

Hello & Thanks for replying Alpinejohn.
As it happens, I am actively supporting 6 or so users of 20.04.3 and have it on my testing rig.
Frankly - I am not impressed with seriously - not at all impressed.
Nothing about it yells out how much better it is - quite the opposite in fact, and this has been my observation since 20.04 came out.

My daily driver PC with 18.04 - on the other hand, is incredibly stable & utterly reliable EXCEPT for when I've screwed it up myself, and except for this strange printing hiccup - which seemed to somehow fix itself without so much as even a restart of anything of any sort.

In fact - I prefer 18.04 so strongly that when that time comes, for my own PC, I'll likely go for the extended support.
I am also in contact with several other very happy 18.04 users who have the same viewpoint as myself.

Now - back to my query in the OP, given that printing is usually a normal sort of a normal function & that the error which popped up for me was totally nebulous, it seems reasonable that there SHOULD be some sort of simplified troubleshooting guide for the function that is NOT as radical & drastic as having to reinstall all the user's apps & transplant ALL their data as well as recreating their preferences.

That is what has me shaking my head whenever someone suggests to 'just upgrade' a PC - which IMO is like telling someone to 'just rip out' their bathroom plumbing & reinstall it - there is not anything 'just' about it.

Best Wishes to You and Yours.