Having some issues with wireless connectivity

Ever since I’ve installed Ubuntu MATE, I’ve been having some serious wireless connectivity issues. The connection randomly drops, then when I attempt to reconnect it, it hangs and never connects until I either reboot or suspend, and even then it doesn’t always work. Anybody have this problem or a solution?

i myself am having troubles too
same laptop with windows7,8,10 works fine
installed ubuntu-mate 15.04 and wifi strength goes down by half and reconnects every few minutes
it could be a driver issue

That’s what I was thinking, but I updated my drivers to no avail. And yeah, sometimes it shows it’s half connected but it doesn’t work.

Hi chaps, do you have your software sources download location set to “Main”?:

Try changing the download location and run another update using a NETWORK CABLE!. :smiley:

No luck. Still having the same issue.

What wireless card are you running?

Try the Windows Wireless Tool:

I have just installed ubuntumate and I am experiencing the same problem. I have tried many solutions in ubuntu however none of them worked.
I can only connect via LAN.
This is my network information. I hope someone here could help me.

[email protected]:~$ sudo lshw -C network

[sudo] password for unknown:
description: Ethernet interface
product: AR8131 Gigabit Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: [email protected]:01:00.0
logical name: eth0
version: c0
serial: f0:bf:97:91:40:81
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:43 memory:90100000-9013ffff ioport:2000(size=128)

[email protected]:~$ lspci -nnk | grep -A2 0280
02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card [105b:e017]
Kernel driver in use: ath9k

Try running these commands and restarting (using your LAN connection!):

sudo apt-get update && sudo apt-get dist-upgrade -f

If the above doesn’t work, try this one:

sudo apt-get update && sudo apt-get install -f

See the URL below and scroll down to the comment that starts I Found the answer