Having trouble updating 18.04

So, I haven't booted up Ubuntu MATE for the first time in a while. I tried to run sudo apt update && sudo apt upgrade.

I got the folowing error:

Hit:1 http://mirror.us-midwest-1.nexcess.net/ubuntu bionic InRelease
Hit:2 http://mirror.us-midwest-1.nexcess.net/ubuntu bionic-updates InRelease                                                    
Hit:3 http://mirror.us-midwest-1.nexcess.net/ubuntu bionic-backports InRelease                                                  
Hit:4 http://mirror.us-midwest-1.nexcess.net/ubuntu bionic-security InRelease                                                   
Hit:5 http://archive.canonical.com/ubuntu bionic InRelease                                                                      
Hit:6 http://download.virtualbox.org/virtualbox/debian bionic InRelease                                                         
Hit:7 https://brave-browser-apt-release.s3.brave.com stable InRelease                                                           
Hit:9 http://apt.insynchq.com/ubuntu artful InRelease                                                                           
Hit:10 http://ppa.launchpad.net/apandada1/brightness-controller/ubuntu bionic InRelease                                         
Ign:11 https://s3-us-west-2.amazonaws.com/brave-apt artful InRelease                                         
Hit:12 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease                   
Err:13 https://s3-us-west-2.amazonaws.com/brave-apt artful Release                             
  404  Not Found [IP: 443]
Ign:8 https://dl.bintray.com/etcher/debian stable InRelease                                                               
Hit:14 http://ppa.launchpad.net/plushuang-tw/uget-stable/ubuntu bionic InRelease                                          
Get:15 https://dl.bintray.com/etcher/debian stable Release [3,674 B]         
Hit:16 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease              
Hit:17 http://ppa.launchpad.net/webupd8team/indicator-kdeconnect/ubuntu bionic InRelease
Hit:18 http://ppa.launchpad.net/wereturtle/ppa/ubuntu bionic InRelease        
Reading package lists... Done                                                 
E: The repository 'https://s3-us-west-2.amazonaws.com/brave-apt artful Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I originally installed Brave via the Software Boutique months ago. I used Software Boutique to remove it, but it still shows up when I try to update.

I did run into an issue with Software Updater not being able to reach the internet (Firefox has no issue accessing the web.). I told Ubuntu to find the best server and was able to install updates yesterday.

Any idea what I should do?

You could try: Control Center > Software and updates, Other software and see if that line from amazonaws is there, remove it, refresh cache, sudo apt update && sudo apt upgrade

As Pavlos said, Control Center > Administration > Software & Updates > Other Software (I assume) and highlight the entry and simply click on "Remove", a picture below to aid you better!.

Well, that solved that problem. Originally, I thought all I have to do was uncheck that link, but that didn't work. Removing it did. Thanks.

1 Like