HDD does very annoying sound in idle

Hello,

I've got a problem with my notebook HDD under ubuntu based distros.

First of all my device details:

My HDD's is always make silent clicking-clackin sound in idle. It's really annoying. If i copying or writing on the HDD sound has gone while the process taking. On windows or non ubuntu based linux (like fedora) everything is fine. HDD SMART is OK.

I tried do

sudo hdparm -B 255 /dev/sda1

and write it to end of the

/etc/hdparm.conf

but not working. If i go hdd to suspend, or set APM (in disk application) the sound still exist.

Anyone can help me, please?

hdparm gets and sets SATA/IDE device parameters, so you need to be using /dev/sda - not /dev/sda1 (which means the first partition on /dev/sda).

Try it first in terminal:

$ sudo /sbin/hdparm -B 254 -S 241 /dev/sda

I added the -S parameter for spindown_time, should you want to configure that too (value 241 is for 30 minutes). See man hdparm for details).

If it works from the command line, add at the end of /etc/hdparm.conf:

/dev/sda {
    apm = 254
    apm_battery = 254
    spindown_time = 241
}

As for resuming: pm-suspend should read the hdparm.conf settings and act accordingly.

1 Like

If you reinstall you can try a different filesystem. Instead of ext4 try xfs for example.

I remember there was a bug like this a long time ago. Back then it was related to the filesystem.

The clicking sound is usually caused by the drive parking its head(s) because of “aggressive” power management settings by the firmware. HDD models targeted for laptop use (Hitachi Travelstar, WD Green, some Samsung and Toshiba models…) are known to have this “feature”. Some Thinkpad BIOSes also try to force the “optimum” settings for power saving (parameter -B) every time AC state changes.

The solution, of course, is to reset the APM mode, which is what we are trying to do here, with the hdparm settings.

In other words: problem is with the HDD (or BIOS setting the HDD parameters), not file system . And definitely no reason to reinstall.

1 Like

Then how do you explain this:

Their power management includes code that overrides the parameters by default and Debian/Ubuntu does not?

It’s quite easy to verify if unloading the head is the cause. After each click run:

$ sudo smartctl -A /dev/sda|grep 'Load_Cycle_Count'|awk '{print $10}'

If the count increases, there’s your culprit.

The clicking could indicate a drive about to fail, but if it makes the click in one OS only, it’s most likely APM issue and easy to fix with hdparm. This is a well known issue.

1 Like

OK, let’s hope this solves the problem. :thumbsup:

Hello samuvuo!

Thanks for your help!
Your solution didn’t work. :frowning:

I also typed

 sudo smartctl -A /dev/sda|grep 'Load_Cycle_Count'|awk '{print $10}'

to the terminal twice and the output is always 118428.

I wonder if setting APM using hdparm is supported by your drive at all. This will tell you:

$ sudo hdparm -B /dev/sda

If not supported, you get back something like:

/dev/sda:
 APM_level	= not supported

The Load_Cycle_Count seems a bit high, how does that compare to Power_Cycle_Count?

$ sudo smartctl -A /dev/sda|grep -E 'Power_Cycle_Count|Load_Cycle_Count'

In a drive suffering from the “agressive APM settings problem” Load_Cycle_Count is multitudes bigger than Power_Cycle_Count (on one of my drives: 1519 / 41005) while a “normal” drive has the ratio closer to 1/2.

1 Like

Hello samuvuo,

I get this

[email protected]:~$ sudo hdparm -B /dev/sda

/dev/sda:
 APM_level	= 254

[email protected]:~$ sudo smartctl -A /dev/sda|grep -E 'Power_Cycle_Count|Load_Cycle_Count'
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       480
193 Load_Cycle_Count        0x0032   088   088   000    Old_age   Always       -       121279

What can i do? Everything i found in google not solve this annoying clicking problem :frowning:

Hi,

The drive in my Thinkpad T520 makes somewhat annoying clicking noises in idle… and it’s an SSD… Not sure what’s really causing the noise. It’s worse when I’m slouching on the sofa and generally stops when the laptop base is dead horizontal. It really sounds like disk accesses though. And yes it really is a pure SSD, not a hybrid or a fake.

Just saying. that even if it really sounds like it is, maybe it’s not the HDD at all.

Cheers.
Memascii

Thanks @samuvuo
after each click sound Load_Cycle_Count got increased.
hdparm -B 255 /dev/sda fixed the issue. it was 128 before that.