HDMI on RPi UbuntuMATE


#28

I’ve just ran through both the fix-missing and fix-broken commands and it didn’t throw up any issues.

I hadn’t installed any graphics card drivers as its running on a Raspberry Pi 3 so didn’t think it was relevant. That said I’ve just checked for additional drivers and got the message ‘no additional drivers available’.

Still think its quite strange that although it can only see analogue stereo output its making a vague attempt to run sound through HDMI.

Perhaps just a bug with Ubuntu on R Pi3 for the moment.


#29

I can’t help you much as I don’t have a RPI box!.

Check out this link and their forum if necessary!:

https://www.raspberrypi.org/forums/viewtopic.php?t=5062

:smiley:


#30

Thanks for your help.

I checked out the linked forum but still couldn’t get it to work. Shelved the Ubuntu memory card for the time being and just got it running as a media centre for the moment…will drop back to it from time to time to see if any updates solve the problem :thinking:

Cheers


#31

Hi guys. I’ve just bought an RPI3 and installed the latest ubuntu mate dated feb27 version for rpi. I have connected my rpi to Samsung TV with HDMI. the display just work like plug and play. but the analog only driver problem affects me too. Please help.
I have the same problems as the guys on top. Connected to HDMI TV.no problem with display, but no sound. and it only shows one analog audio driver as output. even if i do hdmi_2, etc, still the same problem.


#32

Hi Michael,

take a look here and check out this section: “Hardware accelerated video”, it might help you?:


1080p monitor not recognized on Pi 3
#33

Hi wolfman,
thank you so much for replying to my question. i did that much earlier on when searching for answers:
sudo amixer cset numid=3 2

but i tried it again after you told me to. but still, i couldnt detect the hdmi audio output. i tot that my hdmi cable was improperly inserted, hence i took it out and replug and tried again. still cant get it. then i thought maybe my raspbery pi 3 from rs component malaysia was faulty because even when i played youtube or mp4 from pendrive or copied onto my sdcard, it lags and hangs. but its so smooth running browsing and word processing etc. just the video and sound part is faulty.

after searching around for more answers, i found that some ppl said that open elec works fine for videos and 720p playback. so i got another sdcard and installed open elec / kodi on it( from the raspberry pi3 blog referral page). on open elec / kodi OS. the video playback from mp4(pendrive) played smoothly without needing to copy to sdcard. but i cant use the youtube app on kodi.

summary, i think the ubuntu mate desktop is the best looking / working (multipurpose)OS for raspberry pi 3. but maybe the video playback / buffering / hdmi sound driver / output need to be checked. im no programmer, so i dont know what exactly is wrong. hoping to see a new release with all compatibility issues fixed, then ubuntu mate can be perfect for raspberry pi3, and by then raspberry pi 3 can be a true desktop(basic).


#34

Hi Michael,

have you seen this?:


#35

Hello,

Here the same configuration: PI3, Mate 16.04 installed on a 32GB Samsung Class10 SD Card, Samsung TV and absolutely the same problems.
I use the standard Ubuntu Mate without any additional software installed and also did no upgrade.
I found that somewhere in the audio settings a volume slider was set to zero. I set it to 100% and got some HDMI sound. But the sound is stuttering and interrupted even when I play a MP3 from the SD card with VLC.
video playback (MP4) from the SD card is only working when the VLC window is set to a very small size. When set do ~ 1/4 of full screen size, the video freezes immediately.
What to do?


#36

Hi Wolfman,

Yea, i’ve seen that. but it doesnt have any info that could help me.

I have downloaded the 16.04 beta2 file for RPI3, and now putting it into the sdcard.

My method for doing it is really easy, and i hope this info gets to other people.

  1. Plug sdcard into pc using card reader. MUST be used with adapter and adapter set to unlock mode.

  2. Use Gnome Disks(ITS GRAPHICAL easy to use, no need use command line), click format sdcard(optional), then click RESTORE DISK from top right corner of gnome disk. Select your downloaded file. For my current case its the 16.04 beta 2 version. It is (ubuntu-mate-16.04-beta2-desktop-armhf-raspberry-pi.img.xz)

  3. The restore took about 15-20 minutes for me when i did the 15.10.3 file it was going at about 10mb/s. After it was completed, i just plug in the sdcard to RPI3 and it booted in.

  4. But the problem then was the system was only using partly of the sdcard, about 3.9gb or so. the remaining of my sdcard was unused and i couldnt install much thing into it.

  5. I solved that by using GParted Partition Editor. Just click on Resize the partition of PI ROOT. and drag to max so the RPI3 will fully utilize the sdcard.

  6. my current restore image is problematic, it so slow going at 800= kb/s for 16.04 file. i dont know why.

i will update if 16.04 solves my HDMI tv sound problem.


#37

I am having the same problem I have already installed 16.04 beta. This problem is what brought me to here it seems as though I am not the only one. I do not have HDMI as an option to select. How frustrating!!!


#38

So nobody has found the solution yet? I’ve been using an HDMI cable I know sends audio, and I’ve changed hdmi_drive=2. As of right now, I get video from smplayer and omxplayer. I don’t even get video from VLC. I have purchased both codecs so that’s not the problem.

I am really beginning to hate this little computer.


#39

Well, i can say. I have the latest update with all the drivers and their updates. Problem still remains, no sound at all.


#40

There is an extensive amount of detail on the config.txt.
I read this and used several of the audio overrides to succeed in getting the audio available.
Unfortunately I’m in hospital at the moment, so cannot pick up the detail


#41

I was dealing with this exact same issue and then I just now figured it out. Turns out my ignorance was the problem. I was operating under the assumption that the config.txt file was already formated in such a way that all of the lines were being used. I assumed that ## ment the line was commented away and # (only one hash) meant that the line was being used. To make it work I had to remove the single # entirely! Then the audio worked after a reboot. It only took uncommenting the one line hdmi_drive=2. I am sure no one else made such a silly mistake but I thought I would share to help any other noobies out there (like myself :slight_smile: ). Good luck everyone!


#42

Just chiming in here that I’m having the same issue. I can see video (in fact am using the OpenGL Driver, so video is quite good and fills the TV nicely) but despite that I do not see any setting in the sound manager for the HDMI and the display manager\monitor applet doesn’t seem to detect anything beyond the Rpi3 being connected to the TV.

Any idea why this might be? Seems like a really common problem with lots of people posting the same solutions–which would be great if they made a difference. Unfortunately they don’t seem to. Starting to wonder if I should do a fresh install and this time try to fix things via the config.txt before making any updates or using the OpenGL driver (even if this means suffering the bars around the screen until things have been worked out.) I’ve noticed in the past that sometimes configuration needs to be done in a certain order or the changes don’t seem to stick on the x86\x64 side of things…


#43

I also had a long time the same problem…
Thanks @weyandd, I never that the config.txt would be the problem.

So I just delated the ‘#’ in the config.txt which is located in /boot
After a reboot everything works great over HDMI.


#44

Hi all, ive too had the same problem running rpi3 with Ubuntu Mate 16.04, had no sound even through analog output connected to a lil amp… But with no fuss i went to config.txt in the terminal and uncomented (deleted the hash #) in front of the “2 Normal HDMI mode (sound will be sent if supported and enabled)” and in front of the “hdmi_drive=2” and rebooted… Done, all sound comes through to the tv. In the sound options it doesn’t show any hdmi option, even after modding the config.txt file… But still it works… Please note: the “normal HDMI mode” has 2 hashtags ## in front of the line, you MUST remove both aswell as the one # infront of “hdmi_drive=2”. Hope this might help someone.


#45

Wolfman,in this diagram right here it shows the driver as the GF108. I looked that up and its an NVidia driver. Is this the sound settings for your computer or a Raspi?

Could anyone that has HDMI as a sound option post a screenshot of what he output and hardware tabs of their sound settings looks like? Thank you.


#46

I use the HDMI for sound, but am connected through a HDMI to VGA connector which offers a sound output with a headphones socket.
I have the config.txt configured to force audio via HDMI (whether the EDID says sound an option or not).
The sound in Ub-Mate is shown as analog using the BCM2835 (numbers wrong here?).
I cannot at the moment show pics of this
HTH
Derek


#47

Hey. I need help too. I’m using UMate with a Pi3 and editing config.txt uncommenting hdmi_drive=2 gives no result, except making any hardware entries in sound prefs vanish. Anyone got this to work? I’m using version 16.04