How can I restore my Ubuntu Mate 16.04 default audio?

I have a HP mini 210 4000 laptop. After re-installing dual boot Windows 7 and Ubuntu Mate 16.04, I decided to tweak a little on the audio of my Ubuntu Mate. I searched in the net for a IDT High Definition Audio codecs driver for linux and I found one at the Realtek website.

I downloaded the driver “0001-LinuxPkg 5.18rc8.tar.bz2”. And I followed the instructions on how to install it. I was very careful to follow the instruction exactly but when I got to the command make install there were errors. I then rebooted Ubuntu and I was dismayed there was no sound. I looked in the sound preferences, click the tab Hardware and to my dismay found nothing - no hardware just blank. On the tab Output it says “Dummy Output stereo”

Now kindly help me how to restore back the default Audio driver of Ubuntu Mate 16.04. thank you in advance

I typed the command
lspci -v

and the result for the audio is this:

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: Hewlett-Packard Company NM10/ICH7 Family High Definition Audio Controller
	Flags: bus master, fast devsel, latency 0, IRQ 7
	Memory at 84100000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>

Perhaps this can help -

Good luck rex_everett_Tibus.

@mdooley,

thanks for the reply. I have done your suggestion two times still not working.

I have done these

https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

to no avail. well, anyhow there is still the fresh re-installation of the OS, I am positive this will work, its just I had so many cool tweaks with the current one I find it hard to format and install anew.

Again thanks for the reply :slight_smile:

OK, then try this. You know there is going to be a way to fix your problem. Please hold off on the reinstall.

https://ubuntuforums.org/showthread.php?t=803343

@mdooley,

I love your positive vibe. Ok I will try ur suggestion

@mdooley,

how about if i install the audio packages using Synaptic Package Manager? Will it work? Yes it will be a bit of a work since I will have to install audio packages one by one but as long as it works no problem…so will it?

Just to cover the basics, have you right clicked on the sound icon in the upper panel and selected Sound Preferences? The second tab, Hardware might give you the option to select your original sound profile where you can test your speakers. Any possibilities there?

Edit: @rex_everett_Tibus As an added thought, perhaps a re-install of linux-sound-base might help.

@mdooley,

Sorry to say but your suggestion didn’t work and my plan to install alsa-source via Synaptic Package manager didn’t either.

I can’t understand why no soundcard is found
[email protected]:~$ sudo aplay -l
sudo] password for rex:
aplay: device_list:268: no soundcards found...

Yes I have already gone through the Sound Preferences both on the panel and the System>Control Center>Sound and in the Hardware tab nothing to be found no built-in internal audio just nothing. In the Output tab it only has Dummy Outpot Stereo

Is it possible that the realtek audio codec was installed in the /opt directory? Perhaps deleting it (or renamingit) from /opt would help you. Have you looked within synaptic to see if you could remove this codec from there?

I’m fresh out of ideas @rex_everett_Tibus at this point.

@mdooley,

I too am out of ideas. I opened /opt directory but found nothing that is related to realtek I opened Synaptic Package manager searched for anything realtek audio but no packages found except for network and wifi drivers.

Anyways thanks @mdooley, this is still a very good OS tho I didn’t expect messing up the audio is almost impossible to rectify, serves me right for tweaking for curiosity’s sake. At least I have the re-install option.

@rex_everett_Tibus

Well, sometimes the better part of valor is to admit defeat and reinstall. I’ve done plenty of this and you’ve been more than patient for quite a while. Good luck Rex. Sorry I couldn’t have been more helpful.

@mdooley,

hey no problem bro, you have done enough for me and I want to thank you for your help and your advice. Sometimes in this imperfect world things aren’t just perfect so we gotta live with it. I did a fresh re-install so everything’s back to normal :). God bless

1 Like