How can I turn the screensaver /powersavings off?


I have replaced my previous media pc running ubuntu mate 15.04 and kodi with a new cheap intel nuc and mate 16.04. Everything works great, but I am having issues with my screen. After 10 minutes of not using my mouse or keyboard the screen will turn off. When I move the mouse the screen will come back on again, but then I have to change my sound settings back to HDMI.

I have tried these steps to resolve the issue:

  • turned off system/preferences/look and feel/screensaver/activate screensaver when idle
  • changed regard the computer as idle after to 2 hours
  • changed preferences/hardware/power management/put computer to sleep when inactive for to Never
  • gsettings set org.gnome.desktop.session idle-delay 0
  • gsettings set org.gnome.desktop.screensaver lock-enabled false

I use a cheap intel NUC NUC5CPYH with 8 gigs of ram and an 500GB drive. I started using ubuntu mate 16.04 when it was still in beta and kept updating it. I don’t really worry about the sound issue, I guess that will be resolved when the screen stays on. The nuc is connected with HDMI to an AV receiver that is connected to a beamer by HDMI.

Any tip to resolve my problem is welcome! :slight_smile:

1 Like

Try this:

1 Like

You shouldn’t need anything else, wolfman’s guide covers it well. I played with kodi for a short while and I believe that I used caffeine to get around screen blanking.

Wolfman’s tip fixed my problem. Thank’s a lot for the quick reply!

But I still wonder, why doesn’t the display option in the power management have any result? Is it a bug? I can’t remember having this issue with my previous media pc. Make I just forgot that I used caffeine… that’s also possible. :slight_smile:

1 Like

You got it :slight_smile:

Don’t forget to tick on solution. Thanks