How do I add second language? And how can I select and use it?

Hello guys, I just installed Ubuntu MATE!!
And for me, I use English as my primary and Korean as my second language.
But I can't choose Korean and use that... How can I do that?
Please let me know!

Hello @Kevan, if you open the Control Center you should see Language Support under the Personal section. You can select Korean there.

so, there is an installing and removing section at the bottom of that page.
I downloaded Korean Language, but nothing changes.
BTW, I did click apply, but it doesn't change. Also, how do I change English to Korean or Korean to English when I need them at certain time?

Try selecting Korean, logging out, then logging back in.

As you can see, nothing was added at there...

Yap, I went that page and installed Korean, and clicked apply. And then I logged out and came back as yaargh said. But nothing changed... And I don't know how to change my language by keyboard shortcut... Could you tell me that too?

Hey @Kevan, try dragging Korean to the top of the list (like below but with Korean instead of Spanish) then logout and back in.
Screenshot at 2020-05-01 06-38-43

No... Korean doesn't even show on that panel.
At the bottom of the page where it says "Keyboard input method system", people say I need to change that to "ibus" in order to download Korean layout.
But I don't have "ibus" input in that option of changing input system... How can I install "ibus" input system?

Okay, so I solved the problem. Thank you for your help.
The reason it didn't work was because I didn't have "Ibus" as my input in Language Support. Ibus could be downloaded by using the command,

sudo apt install ibus-avro

After that go to Keyboard input method system, and choose Ibus as your input method. Then go to Install/Remove Languages section and add Korean.
If it doesn't work, you might need to restart Ibus. When you look at the top right corner, there will be an keyboard key. Click it, then choose restart.

or by restarting whole computer again.
After that as Yaargh said, you will be able to see Korean at the bottom of the Language menu. Drag it to wherever you want that to be. Then close the window and go to Ibus through ubuntu menu.

At here, go to Input Method and click Add at the right side. Search for Korean and add. Select any shortcut you want to have and that's it. Finally, at the top right, there will be a blue letter that shows your languages. left click it and change it to Korean! μ•ˆλ…•ν•˜μ„Έμš”. 이제 ν•œκΈ€μ„ μ“Έ μ‘€ μžˆμ–΄ λ„ˆλ¬΄

1 Like

Thank you for all your help!

@Kevan cool, thanks for documenting the solution like that.

Another solution i found that doesn't require downloading anything is to go to Control Center>Keyboard:

go to the layouts tab then press +add:

choose the language after that either by country or by language and then press +add.
after that you will be returned to the first menu (same first photo in this post) you can then press the (Options... ) button down there and look for (>Switching to another layout):

and set it to (alt+shift) or whatever you want to switch between languages.
Not sure if that's the "right" way but it's just what worked for me!

this reply had more photos and was really helpful but "new users can't embed more than one link" :roll_eyes:

1 Like

Welcome @Teratron to the community!

1 Like

Hey!, hope i learn more from this forum :grinning:

1 Like