How do I permanently change default audio preferences?

I'm new to Ubuntu Mate. I just installed it on my previously Windows machine a few days ago. So far, things are running relatively smoothly, except that I can't get my sound preferences to stick. Every time I boot up, the the sound settings revert back to their original defaults. I don't know how to make my changes stick. For example, I want the output device to be set to headphones, not speakers. I have to change it back to headphones every time I boot up. The microphone setting doesn't seem to want to stick either. Is there any way to make the changes permanent?

I couldn't get it to work either. At least I can confirm that this is a problem. Are you running Ubuntu MATE 16.04 as well?

I have this problem. I have a “fix”, if not a solution. It requires that you install “indicator-sound-switcher”. This loads in your system tray at boot-up and allows you to pick from a drop-down list of your speakers, headphones etc. It does not solve the issue of why the sound settings keep reverting to default. But, it does make it very easy and quick to switch.

See below for an example of it in operation:

To install it, open a terminal and type the following:

sudo apt-add-repository ppa:yktooo/ppa
sudo apt-get update
sudo apt-get install indicator-sound-switcher
1 Like

Yes, I’m also using 16.04. I wonder if they’re working on fixing this for a future update.

Thanks for the sound switcher. This at least makes the problem more bearable since it means that I don’t have to keep going all the way through the menu into the sound settings box to change it on boot up.

While this didn’t technically “fix” the root issue, I’m going to go ahead and mark this thread solved. Installing your sound switchers appears to have had the added benefit of just defaulting to headphones when I boot up. Maybe it just automatically remembers the settings from the last boot. I don’t know, but it’s working, and that’s what’s most important until we can get a native system wide fix. So, thanks again.

1 Like

@stevecook172001, have there been changes made to the switcher, or has there just been a system wide update that fixed the audio switching issue? My system appears now to be auto-detecting when my headphones are in and out of the jack. It’s great, but I was just wondering what caused it to happen.

My guess it’s probably one of the system updates had the fix in it.

1 Like

Same problem with Mate 19.10 : the "fix" doesn't solve the problem but makes is loads easier to live with. Probably wait until some terminal bash Guru comes along with a scripted solution :slight_smile:
Crispi