How do I reboot with a different kernel? (VirtualBox freezing)

Everytime I start VirtualBox my computer freezes where I am unable to move the mouse and the audio loops. I found a possible solution here: but I am unsure how to boot into the 4.10 kernel instead of the 4.13. I tried holding the shift key when restarting the system but nothing happened. Am running latest LTS on a Macbook Pro.


Hi @Aquassassinator, I think you have an ESCAPE key? (I’m not up on Mac) Press it repeatedly during boot to (hopefully) get the grub screen. Up/Down select Advanced options... and press Enter. All the installed kernels should be showing. Select the one you want (not recovery mode) and press Enter.

I do this a lot on my VMs, I just hope it works on a MacBook.

And yes, Shift held down should do it also. Not sure why it didn’t work.

1 Like

So escape key DID get me to the GUI but when I tried to select the GUI turned grey. If I hit enter it tries to boot, if I press the right arrow key it does the same. Do I need to decrypt FDE as part of the process or am I going wrong somewhere?

Well... the little I played with full disk encryption it should make a separate /boot partition so FDE isn't needed with grub, the boot menu. Sanity check, it says GRUB and its version on the screen?

I've seen the grub menu AND the Advanced options menu render only partially. Escape the Advanced menu, re-enter may straighten it out. Just a guess on my part.

Immediately after starting boot, after GRUB, is when it should ask for the FDE password, I believe.

EDIT: Here's GRUB and the Advanced options menu.

Don't let the mouse cursor fool you - GRUB is keyboard only.

1 Like

Hmmm not exactly, mine is a bit different. It does say GRUB Boot Menu.

Oh yeah sorry I think that was upside down

Interesting GRUB screen.

“Ubuntu” is highlighted. Down arrow should highlight “Advanced options for Ubuntu”. Press Enter. You should get the list of installed kernels and I assume 4.10 is one of them?

At the botton it has an abbreviated list of commands to do things. Where does it fail?

1 Like

It works! Got everything to work by switching to 4.10!

Great! And by the way, you’re not alone having problems with VirtualBox. Good Luck!