How I got my bluetooth headphones to work

I used to not be able to use my bluetooth headphones on UM 14.10 (the bug
exists also on LM17 MATE, and probably on UM 14.04 as well). Here’s to
you in case you’re fighting the same issue.

Type in a terminal:
sudo apt-get purge pulseaudio-module-bluetooth bluetooth bluez-* bluez
sudo apt-get install blueman bluez pulseaudio-module-bluetooth --install-suggests
pactl load-module module-bluetooth-discover

Go to Blueman, connect to your device and set its audio profile to A2DP with high quality sound.
Go to Sound Preferences to select the headphones as your audio device.