How to add sound for Popup Notifications

Curious if its possible to add a sound when the notification bar appears, since I sometimes miss it because I am using a phone and not looking at the monitor. :sweat_smile:

I don’t think it’s possible as such.
If you open a terminal and type in “notify-send --help” you’ll notice there is no option to have a sound playing.
However, some applications that trigger notifications can also have an option to play sounds.
For instance, HexChat (the IRC client) has an option to send notifications in Chatting -> Alerts under the misleading denomination “Show Tray Balloons”, but it can also make beep sounds.


This how I enable notification sounds. dconf should be in your menu :smiley:.

1 Like

@mated Checked there, and I have the same settings as you, but I don’t get sound when receiving an email notification. Seems its like @ouroumov said, it probably is application dependent. Using Geary btw, and didn’t find an option for sound.

Thanks for the info guys. :slight_smile:

1 Like

Sorry for the bombardment of screenshots; this covers most of the rest of any toggled off sound defaults. :neutral_face:

That last one may do it for you, as this app sound enabler is defaulted off; but I don't use Geary.

Don't give up, if you need the feature; there is a way, somewhere! :wink:

Don't worry I don't mind a lot of images. Well, looked through those settings and set the sound same as you, but no luck. I did, however, find one of Geary, and it had a play sound notification. Then found it on Geary's preferences button, I could have sworn that option wasn't there. Anyway, checked marked all the display sounds, sent an email to myself to test, but still a soundless notification. Maybe its still in development?

Some images:

I gleaned through these two, and didn’t find a specific solution for this challenge; but I thought I would let you check them them out for GP, if you haven’t already.

Also, Thunderbird (settings maybe) could perhaps play a role, as would something we missed, or a sound theme debacle, or an absent file or misconfiguration. :neutral_face:

Which version of Geary? 0.11 has been recently released, perhaps this is a bug they’ve fixed. :bug:

The other reason I can think why is if it’s trying to play from a specific sound file (rather then system default)?

1 Like

@mated Saw the help page, and the wiki, nothing there about it just a mention that it has an option for sound notification.

@lah7 Using the 0.11 version gotten from here. Pherhaps the bug is one of those that you spray and it lies there for a min, then escapes. :smiley:

So just an update, I know get a sound when I get a new email. It seems it might have been a problem with Pulseaudio that was fixed in its recent update?

Btw, any way to stop notifications from changing its theme every time I change my windows/icon/border theme? I have it set up to coco, but when I change my overall theme it goes back to the stadard notification theme.

in Gnome3, it uses message.oga

#I used this for jurassic park satellite phone ringtone
ffmpeg -i jurassic.mp3 -c:a libvorbis output.oga
sudo cp output.oga /usr/share/sounds/freedesktop/stereo/message.oga

Has anyone had sucess with ever getting this working? I can’t believe this isn’t a more requested feature. Leave your computer for 10 seconds and you never knew you missed anything…could you have a continuously-running script that monitors the wm whenever “notify-send” is invoked, and when it does, uses something like sox to play a sound?