How to change the avatar in the login?

I have not managed to do. This is what I tried unfruitful:

  1. Place the image with a size of 96x96 png and rename it .face local directory in the home.

  2. Edit or create the file /var/lib/AccountsService/users/username, and add the lines
    Create the file /var/lib/AccountsService/icons/username using a 96x96 PNG image file.
    Making sure that both created files have 644 or 777 permissions, I used chmod and chown to correct them.

  3. through the GUI:
    System> Preferences> About Me> Click on image & select

    None of the above steps worked and beginning to frustrate. Help me please!

Weird, the stuff you tried in 3 worked fine for me.

Make sure you have this set:

System -> Administration -> LightDM GTK+ Greeter settings

Set "User image" to "on".


Thank you, in the end, check again and it was permissions problem.
In the LightDM-gtk-greeter.conf lack of LightDM file to set the variable user-background as true, plus the path to default-user-image did not have permissions for the LightDM group.
Do it from System -> Administration -> LightDM GTK + Greeter settings made me realize. Thank ouroumov!

1 Like