How to change Window manager through terminal?

I clearly think I messed up a few settings of Maye tweak, The two settings I do absolutely remember are :

  • Window Manger
  • Undecorate maximised window

I would like to reset these to Macro and No undecorate, But My desktop loads and I have completely unusable pointer only. Wallpaper does change, because of variety.

I can enter the ctrlaltF1 terminal. But I don’t know the commands to reset these two settings. Please Help.


boot into advanced settings (2nd option in the Grub menu!) and then choose an earlier kernel and boot from that, make your changes and see if it fixes it for you!. :smiley:

:sweat: It didn’t work, I tried bith options in advanced menu one was linux genrix XXXX(some number) and the other was recovery mode in the same number. I am also googing for it maybe I will get a solution.

Anyhow thanx for suggesting. :slight_smile:

Hi @wolfman:

The above article suggests something, What do I replace in <wm> in this:

gsettings set org.mate.session.required-components windowmanager <wm>

Did you read this part?:


open a terminal and write

sudo apt-get install compiz compizconfig-settings-manager

the packets are needed are these: compiz compiz-core compiz-gnome compiz-plugins compiz-plugins-default compiz-plugins-main compiz-plugins-main-default compizconfig-backend-gconf compizconfig-settings-manager libcompizconfig0 libdecoration0 python-compizconfig

then to change in compiz type in terminal

compiz --replace

It doesn’t say what to replace it with?. I don’t use Compiz, sit tight and someone better qualified will help you!. :smiley:

This article also has <wm> setting, Not sure but I might try it:

This command should work :

gsettings reset org.mate.session.required-components windowmanager

You may be able to press ALT+F2, which will open the Run Dialog, and from there typing mate-tweak will allow you to make changes.

If this doesn’t work, as a temporary measure, you can start Marco / MATE Tweak again from the tty console.

  1. CTRL+ALT+F1
  2. Login with your username and password.
  3. Run this command:

env DISPLAY=:0 marco --replace
env DISPLAY=:0 mate-tweak

  1. Switch back to the graphical mode and make your changes again from MATE Tweak.

No It doesn’t work, I do tried startx from X manual, It does start the X server loads the marco but Nothing appears except the wallpaper.