How to compile the ubuntu mate desktop?

I download the new source of ubuntu mate from github. following the wiki, I compiled the mate-common source. It failed. I am beginner, Can someone help me . Did I miss some lib or tools? Thank you so much .

[email protected]:~/work/temp/mate-common$ ./autogen.sh --prefix=/usr
checking for autoreconf >= 2.53...
testing autoreconf... found 2.69
Checking for forbidden M4 macros...
Processing ./configure.ac
Running autoreconf...
autoreconf: Entering directory .' autoreconf: configure.ac: not using Gettext autoreconf: running: aclocal --force --warnings=no-portability autoreconf: configure.ac: tracing autoreconf: configure.ac: not using Libtool autoreconf: running: /usr/bin/autoconf --force --warnings=no-portability autoreconf: configure.ac: not using Autoheader autoreconf: running: automake --add-missing --copy --force-missing --warnings=no-portability autoreconf: Leaving directory.'
Running ./configure --enable-maintainer-mode --prefix=/usr ...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating macros/Makefile
config.status: creating doc-build/Makefile
config.status: creating doc-build/mate-doc-common
config.status: creating doc/Makefile
Now type make' to compile mate-common [email protected]:~/work/temp/mate-common$ make Making all in macros make[1]: Entering directory/home/AP/gengshul/work/temp/mate-common/macros'
make[1]: Nothing to be done for all'. make[1]: Leaving directory/home/AP/gengshul/work/temp/mate-common/macros'
Making all in doc-build
make[1]: Entering directory /home/AP/gengshul/work/temp/mate-common/doc-build' make[1]: Nothing to be done forall'.
make[1]: Leaving directory /home/AP/gengshul/work/temp/mate-common/doc-build' Making all in doc make[1]: Entering directory/home/AP/gengshul/work/temp/mate-common/doc'
make[1]: Nothing to be done for all'. make[1]: Leaving directory/home/AP/gengshul/work/temp/mate-common/doc'
make[1]: Entering directory /home/AP/gengshul/work/temp/mate-common' make[1]: Nothing to be done forall-am'.
make[1]: Leaving directory `/home/AP/gengshul/work/temp/mate-common'

HI @booklin,

why do you want to compile it when the full version is available already?. I assume you want the 18.04 Ubuntu Mate dev version?:

http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/HEADER.html :smiley:

HI @wolfman,
Thank you for your reply . I try to learn the ubuntu mate system and modify the source code. Do you know where I can find a least building guide document. thank you so much.

br
book lin

Hi @booklin,

here are a few links for you:

http://cdimage.ubuntu.com/releases/16.04/release/source/

https://wiki.ubuntu.com/Kernel/SourceCode

I hope it helps. :smiley:

1 Like

Somebody please ANSWER THE QUESTION AS ASKED! I'm trying to test Mate 1.23 on Ubuntu-mate 18.04. Component builds produce

checking for SYNCTEX... no configure: error: "SyncTeX support is disabled since library version 1.21 or newer not found"

Installing libsynctex1 didn't fix it. Nor does configure seem to take a toggle to ignore synctex, whatever it might be.

Same thing here. I'm trying to compile the new Mate 1.24 on LFS and getting the exact same SyncTeX error message, when compiling Atril. I compiled TeXLive and have the libsynctex.so library, but still get the same error.
Mate-Terminal and caja compile without issue. Engrampa is giving me a segfault coredump.

Ok... I got Atril to compile now at least. To fix the SyncTeX problem I don't know why ldconfig isn't picking it up in /opt/texlive/2019 but it wasn't so I made a symbolic link for the libraries to /usr/lib and that worked. I also don't know the correct way of including the kpathsea header files, so I sym linked the kpathsea folder from /opt/texlive/2019/include to backend/dvi/mdvi-lib in the atril source folder and then make worked.
So, not the best or right way, but it worked.