How to control fanspeed?

My fan run on a high speed even if the temperatur is only 40 degree celcius. How do I control that in Ubuntu Mate 16.10. My machine is a HP Probook 4330s.

Thanks :slight_smile:

Hi Laffen_EK

I cannot find a bug about this.

First thought would be if sensors can be calibrated or are good.

There are work-a-rounds like this one. Just not a proper fix :frowning:

Oh… I was not accurate about this. I am used to an old fanless Dell laptop and my fanless Chromebook, so the HPs fan is probably normal speed… And if I manage to slow it down, I probably burn the laptop in a year. So it is not a Ubuntu Mate issue, its me who want it more quiet :slight_smile:

What display driver are you running? In terminal:

inxi -G

Are you offered any additional drivers? In terminal:

software-properties-gtk --open-tab=4

Look like this. I did not change anything.

Found this in "Welcome + Software"

It is really not a big problem. I just want to set min to 50 degree and hope the fan not start so often. I’m a bit spoiled… :slight_smile:

No, no problem. I just thought there would be additional drivers. Guess we can close this then :wave:

1 Like

I’ve been thinking about this same problem, but for a Windows computer. The options are to just buy a quieter fan, clean your existing ones (and might as well clean the whole computer); and adjusting settings on your motherboard. There programs for both Windows and Linux for this, but you can also do it in the bios. My gigabyte mobo has a utility called EZ tune, but it can also be adjusted directly in thew bios. Mine has a setting under Fan Control named “silent.” I have yet to try messing with it, as this is my music computer, and I’m very conservative with it. but I may give it a try. Anyway, there’s lots of info available online about this. Gamers are especially concerned with fan speed for some reason (I’m not a gamer so I wouldn’t know).

1 Like

I had totally forgot about fan control in bios. Good call :slight_smile:

Perfect. I could shut off “Fan always on when power cable connected”. Thank you all :slight_smile: