How to disable Plank autostart on login

I accidentally started Plank and now I cannot get rid of it short of uninstalling - it always launches when I log in and I do not find anything in either the Plank preferences or the Ubuntu MATE Startup Applications to disable it.

Apparently it was saved in my custom panel layout - switched to Redmond (don’t remember if I closed Plank beforehand) and switched back to the custom layout then saved it again.
Now plank no longer autostarts.
I guess it probably started in the first place when I selected the Cupertino layout yesterday.

1 Like

It auto starts when the MATE session is loaded, use the dconf Editor to disable its dconf entry here:


Click “Set to Default” for dock.