How to downgrade proprietary AMD driver?


First of all I would like to say I like MATE desktop, I really like the Ubuntu MATE distro and I really appreciate all the work of all the people involved.

Few hours ago I got updates for my laptop running Ubuntu Mate 14.04. The proprietary AMD drivers have been updated. Now I’ve got 15.201-0ubuntu0.14.04.1 version of the driver. When trying to play even the low-resolution video (360p or even lower) in VLC, the performance is terrible - low framerate, high APU temperature, the video is simply “unwatchable”. This is the first version of fglrx showing such a performance drawback. I would like to revert to the previous fglrx version, which was OK. The older version number is (probably) 15.200-0ubuntu0.6. But how to do this?

I tried following commands:
sudo apt-get install fglrx=15.200-0ubuntu0.6
and also some more variants of the version number e. g.:
sudo apt-get install fglrx=2:15.200-0ubuntu0.6
However, always the same result
E: Version '15.200-0ubuntu0.6' for 'fglrx' was not found

Somebody please help. Would somebody be so kind and tell me how to install the above mentioned older version of the fglrx?

Some additional info:
The APU is AMD E-350 with Radeon 6310 integrated GPU.
Using the open-source driver does not solve the performance problem. The performance is even worse.

You can list the versions of a particular package in the repos with ‘apt-cache madison -pkg-’.
Could you check which versions are available in the repos for you (I’m not at my home pc now).
If the older version is not in the repo, I’d recommend first switching to the free drivers, then
download an older version from the AMD website and install it manually.

Hope this helps

You can go to control center and then additional drivers . There should be listed the versions of the driver . Free or non-free does not matter

Rolf_Jacobs & IvCHo: Thank you both for replies!

Rolf_Jacobs: Good tip with apt-cache madison -pkg-. There are two versions available, I can force to use older one using the Synaptic Package Manager. The newer one is the problematic (problematic for my PC) one. The older is 2:13.350.1-0ubuntu2. There was pretty ugly memory leak in the non-free AMD graphic drivers and it took the developers very very long time - several releases - to fix this issue. I wonder if the 13.350 version have this issue fixed or not. I will probably have to try to find it out. I will rather not to install the manually downloaded driver yet. I used Fedora (MATE spin of course :slightly_smiling:) for some time (circa 1.5 year?), there were no packages available and it required the manual installation of the downloaded drivers after each kernel update. But before doing so, it required to patch the source files in the package, otherwise the installation would crash. Luckily, there were some blogs of the good guys, who tested the installation, created the patches and wrote the step-by-step articles for the good of the other users.

IvCHo: Sorry, but there are no versions listed in the Additional Drivers Menu Item / Control Panels Item. There are options to choose the open source driver or proprietary driver from fglrx or proprietary driver from fglrx-updates. Taking a look at the packages using Synaptic Package Manager, I believe the latter two choices contain the same version of the driver (15.201-0ubuntu0.14.04.1), which is the problematic (problematic for my PC) one. But may be I misunderstood something, if there (somewhere) is the possibility to select the desired version of the driver, please tell me.


The best solution for me would be using the 15.200-0ubuntu0.6 / 2:15.200-0ubuntu0.6 version of the driver. This version was mature, it had not the memory leak mentioned above, and the performance was good enough for me. I will give it few more tries to google some solution, in the meantime I would still appreciate any hint / tip / suggestion.