How to easily access ntfs hdd?


English is not my best...i'm living in Chile...i hope you guys will understand...

I fired windows - too much problems - and tried linux os17 zorin...ntfs hdd were automatically mounted but i fired zorin because the internet browsers had a lot of refresh problems and i'm mostly working on internet.

Now i'm working with the last version of Ubuntu Mate but it's not possible to automatically mount ntfs hdd and i have all my files and work on an external ntfs hdd :thinking:

Error message : "wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program or other error" i tried with all usb ports and it's the same.

I read a lot of things about ntfs-3g or things like that but i really don't know what i have to do.

There is no simple option to activate with Mate ?


1 Like

Welcome @yservant to the community!

1 Like

using the comando :
sudo apt list --installed | grep ntfs

i have this result if it can help :
libntfs-3g89/mantic,now 1:2022.10.3-1ubuntu1 amd64 [instalado, automático]
ntfs-3g/mantic,now 1:2022.10.3-1ubuntu1 amd64 [instalado, automático]

i tried this comando :
sudo ntfsfix /dev/sdb1

result :
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.

but i have the same error when i try to access the hdd..."wrong fs type, etc..." :unamused:

i don't want to go back to windows but i can't spend time like this, i nedd to access my work...

Any idea ?

1 Like

You have ntfs-3g so you should be able to access ntfs drives but ... if this is a dual boot pc, windows did not shutdown properly and left the disk (/dev/sdb) in a 'dirty' state. You need to go back to Windows and tell it to shutdown and not hibernate the disk.

I ran a test with a VM, created a ntfs volume and I can read/write without issues.


Thanks for the answer but before Mate i had Zorin os17 and the hdd was mounted correctly. I tried it some minutes ago with the windows notebook of my wife and the hdd is ok.

So, to resume :

  • i can access this ntfs hdd with windows and zorin os 17.
  • i can´t mount it with Mate and i prefer Mate...sure it's just a option problem but i don't know what i can do :slightly_frowning_face: :slightly_frowning_face:

my notebook only has a fresh Mate install, it's not a dual boot.

i tried another thing i encountered...
/dev/sdb1 /mnt/Arwen ntfs-3g quiet,defaults,rw 0 0 in the etc/fstab file.

before i created a /mnt/Arwen folder as explained in a video...but the external hdd simply desappeared from the caja app... :joy: :scream: :weary:

i think i will have to go back to window$ if i want to access my work :sweat:

Maybe i encountered a beginning of explanation...

i tried to connect other ntfs/fat hdd/pendrives i have...

result :
pendrive kingston 2gb/fat32 - working
hdd seagate 1,5 to usb3/ntfs - working
an old TOSHIBA MK6006GAH 60go/ntfs - working

2 ntfs hhd are not working...same brand hitachi 5k750 - 750 go/sata3.

a drivers problem ? Mate need something drivers/comando sudo/another thing to recognize correctly hitachi hdd ?

i tried all i'm able to understand +/, i don't know what i can do...any idea ?

you could use gnome-disks (system > preferences > hardware > disks )which should show on the left side the disks and mount them. I tested my VM again ,created a 5GB disk, and was able to mount it.

sudo umount bob (disk is gone)

sudo mkdir /mnt/yann
sudo mount /dev/sdb1 /mnt/yann  (disk is mounted)
/dev/sdb1           5240828    26812     5214016   1% /mnt/yann

mount (mounted as rw)
/dev/sdb1 on /mnt/yann type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

lsblk -fs
sdb1 ntfs               637604FE68B80E25                          5G     1% /mnt/yann


Thanks for the answer but the problem is only with my 2 Hitachi hdd (drivers problem i guess but i have no time to look for linux drivers.)

I tried all my pendrives and it works plugNplay.

I tried all my others ntfs hdd and all are working plugNplay (fujitsu, maxtor, seagate, wd).

I bought 2 big pendrives and i will transfer all files from hitachi hdd on 1st one and prepare the other one to be bootable with mate and use it to work on any computer with my linux system.

Thanks again.

1 Like

then install a second Zorin OS 17 system with your USB stick. . Then the Grub boot manager with all systems on your PC will appear in the start menu.
The Linux Mint system even repaired the Windows partition for me. So I was able to start Windows again.

Sorry, i took my time to answer but i had a lot of work and outside the city...

Thanks for your answer but, no, i will not install os17...i need an OS that works good...when i was young i enjoyed playing with os, looking for solutioms, coding etc... Now i have no time for this.

But i tried this solution and it worked with some HDD but...we need a computer with window$... just using chkdsk / f...and i recovered the access to the HDD ans all my files.

Just 1 HDD doesn't work now...1,5To Seagate...ntfs formatted with gparted on linux system, it's ok i can access it...i connect it to a wind computer, it's not recognized, i saw in HDD administration but nothing too...i connect it 1 more time on linux and it's not recognized...i think the HDD is dead. 

Thanks again.

don't know what happened with my message...some words in bold mode, others in color... :sweat_smile: :grin:

The OS (Ubuntu MATE) is working fine, you wrote you can access other HDDs.

What is going on with that disk I have no idea.

For sure this sounds like hardware problem. (drive, cable or enclosure)