How to get Apple Magic Mouse to work - 18.04

New to Ubuntu Mate and love working with it. Please note that I am not real tech savvy although a hobbyist.

Full install of 18.04 on a MacBook Air and everything working fine. However, I am currently using a corded mouse and have connected/paired the Apple mouse through bluetooth fine. It’s recognized however any movements are not working on the computer.
I also have an iMac with Mate that is doing the exact same thing so believe I have done something wrong.

I have used the default code from Apple (0000) through the pairing process and as said, the mouse is recognized and shows up under Devices however movements are not happening.

Any assistance would be greatly appreciated.

PS. I realize I can just buy a new wireless mouse and it will likely work fine however after 9 years it’s hard to change!

Hello Oldtom

As this post and all the comments below it shows:

setting up a magic mouse is not that straightforward.
You may find less frustration and more happiness with another mouse. :slight_smile:

LOL…I figured as much and likely will go that way but will look over the instructions you have provided.


Yep…looks beyond my abilities so will move over to Logictech and look at MX or one of their other models.


dont say that please !!!
you can do it by following the next steps.

Open up a terminal with ctrl + alt + T

u will need kernel 4.18 or higher
find this by using the following command
uname -a if is higer than 4.18 then continue.

sudo apt-get install dkms
git clone
cd Linux-Magic-Trackpad-2-Driver/scripts
chmod u+x
sudo ./

After completing this steps you must pair your bluetooth magic mouse.

This driver is based off of the work of @robotrovsky, @svartalf and probably others.

1 Like

Thanks for this and will give it a try!!

I have a Mac Mini 2011 I have thinking of doing a full install on. Did you wipe your hard drive? I would like to just switch it to 18.04 completely but I am nervous.

Yes, ran a live session to check it out and then did a full install. All worked fine.