How to get widevine on Chromium? [21.10]

Is there any way to get widevine running on 21.10? I've tried using the method here:
Which worked on 20.04, however it doesn't seem to work on 21.10, as it just ends with this:

Is there any other way to get widevine working on here or am I just out of luck?

I'm no Docker guru, or a Raspberry Pi guru, by any stretch. But let me chip in: Try rebooting. If you did an apt-get upgrade right before trying to use the Docker container of Chromium, and the upgrade installed a new kernel, the proper kernel modules will not be loaded since the operating system will be stuck in a somewhat inconsistent state.

You can find out more at

1 Like

I did end up flashing an older kernel due to the audio being broken on the latest version. That could have something to do with it perhaps?

Yeah, I think so. Again, reboot after a kernel update, and if that fixed the problem, then bam, there we go. :slight_smile:

To get Widevine support for Chromium browser running on Raspberry Pi OS, update the software sources, update your system, then install libwidevinecdm0:

sudo apt update
sudo apt full-upgrade
sudo apt install libwidevinecdm0

Restart your Chromium web browser in case it was running, and that's it.

1 Like