How to set up hibernate on mate 18.04

after a fresh Mate install, I edited grub and updated grub and initramfs.

    cat /proc/swaps

Filename Type Size Used Priority
/swapfile file 2097148 0 -2

cat /etc/default/grub | grep resume

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=/swapfile"

it does not recover the previous workspace after hibernation, but it is not a clean restart as the network does not work. checking for a sleep process does not find any.
any ideas?

Take a look at this ...

I had already done that and it still does not work. is it possible hibernate needs to resume from a non-root partition? I have another mate where swap is on its own partition and it works fine. this new install has a single partition and uses a swapfile as I show. Is that a problem??

Have you tried passing UUID as the parameter (instead of /swapfile) ...
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash resume=UUID=xxxxxxx”
don't forget to update-grub after mod.

There is no uuid. the swaapfile is A FILE, not a partition.
I posted the output of cat /proc/swaps which clearly shows that.

my mistake, sorry...

I discovered it is not possible to use a swapfile to hibernate. There is a workaround by using uswsusp and the solution is here:

I will just create a swap partition and hibernate the usual way.