How to suppress kernel boot error messages?

Hello, when i boot i see these messages but everything works fine.

i want to hide this and only show the splash screen.

here is a video(.gif) if you don't understand me.

Hi @avestruz123,

can you first tell us what hardware you are on please. :smiley:

System: Host: aspire-ES1-531 Kernel: 4.9.0-040900-generic x86_64 (64 bit) Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial Machine: System: Acer (portable) product: Aspire ES1-531 v: V1.19 Mobo: Acer model: Aspire ES1-531 v: V1.19 Bios: Insyde v: V1.19 date: 07/07/2016 CPU: Dual core Intel Celeron N3050 (-MCP-) cache: 1024 KB clock speeds: max: 2160 MHz 1: 957 MHz 2: 479 MHz Graphics: Card: Intel Device 22b1 Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: [email protected] GLX Renderer: Mesa DRI Intel HD Graphics (Cherryview) GLX Version: 3.0 Mesa 11.2.0 Audio: Card Intel Device 2284 driver: snd_hda_intel Sound: ALSA v: k4.9.0-040900-generic Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k Drives: HDD Total Size: 1000.2GB (2.6% used) ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB

You could edit /etc/default/grub and add, acpi=off at the end of GRUB_CMDLINE_LINUX_DEFAULT
e.g. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off" then sudo update-grub and reboot.

acpi=off disables some features, i only want hide those messages.

Does this help?

Hi, I solved it with a simple parameter loglevel=0
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=0 splash"