How to test Caja-Actions on Ubuntu MATE 14.04 and 14.10


#16

Oh I meant to add too that that even if you install the deb file directly from project’s github page, the installer fails to copy the help files to the correct location.

I’m going to build it myself from source and see if I can get it work.

EDIT: I built from source (both original and your fork) and had the same problem with the help files not being included where they are supposed to go.


#17

Yep, I looked at the make files. They need a patch to install the xml files.


#18

@Wimpy I’m pretty sure the offending file is docs/cact/Makefile.am and the following line is incomplete:

HELP_FILES = index.docbook legalnotice.xml

If we add the rest of the XML files in the docs/cact/C directory to that list, I’m guessing that will work. I’m not on my dev machine at the moment so I can’t test it. Will re-build it again when I get home tonight. If it works I’ll patch it and do a pull request unless you beat me to it!


#19

Thanks for reporting the issue.
I’ve upload a fixed 1.8.0 tarball at fedorapeople :wink:
https://raveit65.fedorapeople.org/Mate/SOURCE/


#20

@raveit65 You’re very welcome. Thanks very much for patching it. I managed to build it with my modified patch and it worked but I haven’t had the chance to push it to my fork on github - you’ve saved me the effort!

@Wimpy is that enough for you to get it into your ppa?

EDIT: Nevermind, I just realised that @raveit65 and NiceandGently are the same person!


#21

@raveit65 Thanks for your help, I really appreciate that.

@CGB raveit65 it one of the core MATE Desktop development team who also maintains a few ports of GNOME2 applications as community projects. I mentioned the difficulty we were having on IRC and, as usual, he put the effort in.

I will release new packages to the PPA later today :smiley:


#22

I second the thanks to you both. I wish I could have done more to help given how much I use caja-actions.


#23

caja-actions 1.8.0 is in the PPA and help works :slight_smile:


#24

Out of interest, what is the difference between using caja-actions and just writing a script and dropping it in the .config/caja/scripts folder and then accessing it from the right click scripts menu?


#25

It is basically a GUI to do just that.


#26

Does Caja-Actions allow one to create scripts without having to actually write the code in the same way that windows users can create, say, macros by “recording” them and so having the code written for them? If it does, I can certainly see its utility. If it does not, however, I fail to see how it saves time and work using Caja-Actions instead of just writing the script in a text editor and then sticking it in the scripts folder


#27

No it doesn’t allow you record macros and as @Wimpy stated it’s basically a GUI around the ability to add a script to the context menu in Caja.

That said it makes a couple of things easier than just dropping a shell script in the scripts folder. For example, it makes it easy to filter by mimetypes. I’ve created a bunch of scripts to process markdown files and they only appear as an option when a markdown file is selected in Caja. Likewise you can limit the script availability to certain folders. That keeps things neat and tidy if nothing else.


#28

Okay, I can see that’s quite useful.


#29

Hi folks

A question: are Caja-Actions meanwhile a stable implementation for daily use or do I risk any problems with install? I’m prying to find out what I can do with them and I guess there are some practical futures to tune up my UM 14.4… :sunglasses:


#30

It’s as stable as the Giza Plateau and I’ve tested in on four machines all running 14.04


#31

Awesome response! :grinning: Then I will build my Pyramide on it! :wink:
I see more than more, UM is a house build on stone and not on sand and it shall grow for thousend of years! (My dramatic input for Monday morning)


#32

Exactly the right metaphor! Ubuntu MATE is the foundation; what you create with it is the important thing!


#33

Over in General Discussions, @IvCHo was asking about a Copy to function similar to Windows and asked if it could be implemented in Caja-Actions. I’ve created a basic proof of concept and cross-linked it here to demonstrate what you can easily achieve with Caja-Actions, a script and Zenity.


#34

How can I make this script work on Caja Actions?

It doesn’t work in Caja-Actions but it works only if I put it in the in the.config/caja/scripts folder.


#35

I did some tests on Ubuntu 16.04.
With Caja- Actions the scripts (“Print” or “Print with …”) only work on the selected files.
That is, they lack the additional functions of selecting a folder or right clicking on the open folder, printing all the files contained in it, as it happens with the other method.
The error message for non-printable files occurs regularly.

Route: bash
Parameters: /home/username/config/caja/scripts/Print %B
that is, the path of the script with the addition of the% B parameter

The% F parameter does not work, I’ve also tried some other parameters with no results.
However, in this way you have the command directly in the context menu, without going through Script.