How to Undelete a Deleted Folder(s)

Got any tips for undeleteing a folder that was full of folders that each had a movie in them?

TestDisk (PhotoRec) can recover deleted files and pics. However its not known to be 100%, mileage will vary.

1 Like

Yeah, i tried ntfsundelete, but all the columns showed zero bytes and 0% to recover. I suspect its not scanning within the folders. I had a media folder setup up for Kodi, so my “movies” folder contained 800 individual directories, with one movie per folder. So right now testdisk is 6 files into the recovery. I have an xml list of what i had, so I suppose I could go off to the dark corners of the net and get them back.

Thanks for all your help.

1 Like

TestDisk can take hours.

You weren’t kidding. It’s at 32 since you replied.

Another vote for TestDisc. It’s been a trusty tool. As pointed out already, it can take a loooooong time. My max is 32 hours when processing a friend’s 120 gig hard disk full of movie files. Just let it do its thing.

I usually first clone the disk (especially if it’s damaged) and operate on the clone to keep the original safe, should something go wrong. I’ve used plain dd for cloning in the past, but ddrescue has proven to be better.

Disk duplication:

ddrescue homepage:

1 Like

For anyone new to Testdisk, here’s a guide on how to use it:


Quick question: Its at 147 now. Before I started this mass recover, I tested it using the lower case c command (copy current file) and moved to the directory I wanted it put ( on a completely separate disk). It worked. One file appeared in the designated folder.

But there’s nothing in that directory now, even though 147 files have been recovered. Does it not write them til its done recovering them?

Ok testdisk undelete isn’t saving the files to where i tell it too, but photorec is… Which is disappointing because photorec doesn’t retain the filenames.

I accidentally deleted a directory with Caja, using shift. I unmounted it right away, and am running testdisk.

I have told it to recover to ~/RECOVERED, and like Evil-Ways, nothing seems to be showing up in that directory. The count of files is up to 73631, with 0 failed.

Will they not show up until all have been found?