Hp 3015 print drivers are so slow at printing

I have installed "hplip-3.16.3.run drivers for the Hp 3015 printer and it takes forever to print a 18 page PDF file. I’m talking over a hour whereby, I gave up and stop the job

Could it be the spool settings? Look for a option to print directly to the printer.

Hi @Foreman_cr ,

I would install and use the following package via the terminal (Ctrl + Alt + t):

sudo apt-get install hplip-gui

See also:


I have just tried the terminal input of: sudo apt-get install hplip-gui and the same problem persist. I get the following error:

Do you have it connected via USB?, have you tried a different cable/USB hub?. :smiley:

1 Like

I have not tried a different usb cable. I have another windows 10 machine right next to the Linux machine. I move the cables over to the windows 10 machine and all works well. I have found that the HP software defaults to 120 dpi for all printing. This maybe useful for pictures but for a laser jet whereby it does most of it prints as text. This is over kill for most of my use. This has helped a little but it is still slow…


have you opened HP Device manager (System > Preferences > Other > HPLIP Toolbox) and checked the "Print Settings"?:

I have made that change with no help. I notice an error when running “diagnose HPLIP drivers” where it said that I need Python-3 development program. I found that software here:


It helped but I am still getting the HPLIP Device status error (5012). The printing is faster but no where need what the print speed of a windows machine

I know what you mean, I couldn’t get my printer to print a simple document the other day, I had to use the HP repair tools in Windblows 10 to get it back on track so to speak!. :smiley: