HP s5-1414 video issues

Hello,

I have a recently acquired HP Pavilion Slimline s5-1414 Desktop PC.
The integrated graphics has two DVI outputs, which are supposed to function simultaneously, they don’t. When I plug a second DVI monitor in the adapter fails and I can’t even unplug one and have it work. The first time this happened I figured I’d fried the graphics card so I bought a GEFORCE GT 710 NVIDIA card and installed it. It worked perfectly until it didn’t because the machine froze (I’ve since been through this a few times). Upon removal of the added graphics card (physically removed from the system) the integrated adapter works again, with a single display, add a second display and the whole story unfolds once more.
There are no BIOS settings to completely disable the integrated card or to switch it to dual display capabilities (though according to the factory specs it’s designed for that) http://support.hp.com/us-en/document/c03506147

This is strictly a hardware issue, besides the machine locking up when the hardware goes wonky

Any thoughts on this? Here are my system specs

System: Host: s5-1414 Kernel: 4.4.0-38-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: Hewlett-Packard product: s5-1414
Mobo: Foxconn model: 2ADA v: 1.00
Bios: AMI v: 8.08 date: 09/14/2012
CPU: Dual core Intel Core i3-2130 (-HT-MCP-) cache: 3072 KB
clock speeds: max: 3400 MHz 1: 1649 MHz 2: 1684 MHz 3: 1770 MHz
4: 1609 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Sandybridge Desktop
GLX Version: 3.0 Mesa 11.2.0
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-38-generic
Network: Card-1: Ralink RT5390R 802.11bgn PCIe Wireless Network Adapter
driver: rt2800pci
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
Drives: HDD Total Size: 2000.4GB (0.5% used)
ID-1: /dev/sda model: WDC_WD20EZRX size: 2000.4GB

I’d really appreciate some help here

I don’t know but you should test if your problem exists in both UEFI and Legacy mode. There is often a difference in behaviour depending on which mode you install in. So if nothing else works try installing UM in a different mode.

Last option: Install Windows and see how your hardware behaves. This might give you a better understanding of the problem.

There is also the risky option of upgrading your UEFI/BIOS if it hasn’t been done. Your current version is dated 09/14/2012.

2 Likes

Have you tried the two DVIs in Windows?

I’d recommend creating a live windows 8 usb stick and seeing if it works in that, if you don’t want to mess about with a full install.

It might also be worthwhile updating the BIOS to 8.20 rev A (released 2015). Actually, I’d start with that. Definitely.

1 Like

Thanks @SFromley I’ll try to find someplace with instructions on updating the BIOS, the issue with using both DVI ports prevents the machine from even booting, let alone finding an OS, so I know it wouldn’t work in Windows either. According to the specs, an add-on graphics card is supposed to automatically disable the integrated card, but it doesn’t. It works (for awhile) after the integrated card has failed, and then after awhile the add-on card will fail and I have to physically remove it. Then the machine will boot with a single DVI plugged into the integrated card.
This is beyond weird to me

Thanks for the suggettion @mrtribute, but the machine won’t boot at all in UEFI mode, comes back with a “bootable disk not found” error. It wouldn’t even take the Live Image on USB stick when I started the install

I have one machine running Windows 8, I don’t use it much. I can’t find where you can make a bootable backup…What I know about windows is mostly what I can remember from 2009 when I said goodbye to Windows XP…can this BIOS update file safely run from WINE?

I wouldn't bet on WINE. I just checked; It's possible to download a Windows 10 ISO directly from Microsoft. You can do it even from Linux. (website complains a little but still lets you do it)

Use the Windows program Rufus to get the ISO on a USB-stick.

When you install skip activation. After installation you should be able to use it for 30 days or something like that. Enough to update the BIOS.

It seems you are not the only one doing this :wink:

Thanks! I like your suggestion for solution, though I don’t like the thought of contaminating my machine with the microsoft virus…oh well…looking like a 3 hour download with my current intermittent quality internet…I’ll catch you on the flip-flop :slight_smile:

Applied the BIOS update, now it alternates starting with dual integrated display support and needing the add-on card…which is a step in the right direction…at least when it insists on the integrated adapter it’ll boot with both DVI displays functioning.
Is it possible that the CMOS battery is weak? It’s definitely not dead, but that’s as far as I can think about it right now

As far as I know the battery is only there to power the BIOS clock when PC is turned off.

“If your computer is losing its time or date settings, or you are receiving a message CMOS Read Error, CMOS Checksum Error, or CMOS Battery Failure, the CMOS battery needs to be replaced.”

From here:

1 Like

I know, but it was a stone I needed to turn over…it’s got a new CMOS battery now at any rate…
This is very weird, each time it powers off it switches from only booting with the integrated card, to only booting with the add-on card, and back. But it’s basically each time it’s powered off and then turned on again, it doesn’t matter how long it sits so it’s not a thermal issue…

This is a motherboard/BIOS issue, I’ve stripped the machine of usable parts and chucked the remains…it’s not worth the headache of dealing with, I’ve got plenty of other newer machines to work with

2 Likes