Hp8600 Officejet Pro & Ubuntu Mate 16.04 - lost on re-boot

I am new to this, I have installed Ubuntu Mate 16.04 on an IBM thinkcentre m51 using the above printer. I installed the hplip package as instructed by the os. My printer showed up, printed a test page (first problem - no color), and when I reboot the system I have to re-enter the "hp-setup ip address command to re-connect w/printer. I am looking to get away from windows os forever and this is the 1st distro I found I could work with. Any suggestions or places to check would be appreciated in advance. Running the windows install cd thru Wine/winetricks fails.


Are you using this printer as a network (conected printer), either via a LAN-cable or on a wireless network?

If you are, have you assigned a fixed IP-address to this printer?

If you have not yet assigned a fixed IP-address to this printer go into your router administration software and set a fixed IP-address for the printer. I believe that this is the information you are being asked for.

If on the other hand you have conected the printer to your computer via a USB-cable I’ve no idea what’s going on. If this is the case I would suggest you try adding the printer via the printers dialogue in the control centre.

I use an OKI network printer (LAN) and a HP inkjet via USB. I have used an HP via LAN before though (briefly). :slight_smile:

I am using the 8600 as a network printer. I do have a USB cable for it tho. Also, I am attempting to “share” the printer between 2 different computers (both on wireless), maybe I should USB the IBM m51 and leave the other as wireless. That would just leave the lack of color for the Mate system.

One other response. I did get an IP address to use on Mate, when I reboot, I use the “hp-setup (ip address)” and the 8600 is found, will then print, but no color what so ever.


I don’t “do” wireless - I have a thing for nice cables. So all aspects “wireless” will need someone else to help.

Have you worked your way through the options in the “HPLIP” interface? Have you checked all the other places where the colour of your output (application you’re printing from) can be set/modified?
Windoze is famous for having around three different places where print “options” can be set. As far as I can tell in Ubuntu-Mate there are only two - the application sending the print job and CUPS/HPLIP (in your case).

I’m getting to the end of my suggestions - are there any “power-users” who could help out here?

I hooked the printer up to USB and solved one half of the issue, still won’t print in color tho.

I use a different HP printer so this might help or not. I installed HPLIP [HP Linux Imaging and Printing] that’s available from the

Welcome Screen >> Drivers >> Printers

I’m able to print via WIFI from a MAC and UM.

I think I have solved this problem, first of all thanx to all who replied to help!!! I just printed a color doc from my laptop and it seems the issue lies with the printer. The first checks I did were just text docs and all was well. Time for a new printer/print head. Thanks again for the help guys.