Hplip missing files

This aforementioned file is contained in the package printer-driver-hpcups.

Install it with:

sudo apt-get install --reinstall printer-driver-hpcups

About HPLIP please make sure that you have installed hplip-gui package and do not forget to run hp-plugin as your MFP needs it.

Thanks for the reply, I am now getting a printer error message HPLIP Plugin I have checked via Synaptic and the gui is installed but I cannot run hp-setup from the command line as the message reads "hp-setup command not found"

The below command:

sudo apt-get install --reinstall hplip-gui

should help. How did you installed HPLIP before? From deb-package or from run-binary?

I have tried your suggestion with no success unfortunately. I have tried installing HPLIP from both the repository and the run binary, this is maybe some lack of in-depth knowledge on my part and perhaps I have inadvertently messed the whole thing up.
Is it possible to wipe the slate clean by uninstalling the whole package and start again?

To uninstall you can do the following:

# 1 - remove HPLIP deb-packages
sudo apt-get purge hplip hplip-data hplip-doc hplip-gui hpijs-ppds \
libsane-hpaio printer-driver-hpcups printer-driver-hpijs
sudo apt-get autoremove --purge

# 2 - remove using HPLIP binary uninstaller
wget https://nchc.dl.sourceforge.net/project/hplip/hplip/3.20.3/hplip-3.20.3.run
sh hplip-3.20.3.run --noexec
cd hplip-3.20.3
sudo python3 ./uninstall.py
sudo rm -rf /usr/share/hplip/

and then reinstall deb-package with:

sudo apt-get install hplip-gui
sudo apt-get install ubuntu-mate-desktop # as it was removed on previous steps

See also:

1 Like

I have followed your instructions and I am making some progress, in the terminal hp-setup is now responding but I am now getting the error message "/usr/lib/cups/filter/hpps" not available: No such file or directory" when trying to install the colour laser printer. I have not tried the MFP yet I thought I would deal with one printer at a time.
Both of my printers are hard wired network printers if that helps(or not)


sudo apt-get install printer-driver-postscript-hp

I tried that suggestion but it was already installed and I got the same error message.
thanks for your ongoing help!!

Hi Chris,

try the following packages:

sudo apt install printer-driver-hpijs hpijs-ppds

It should help?. :crazy_face: :smiley: :grinning:

Hi Wolfman,
Still no luck im afraid it is returning "Idle - File /usr/lib/cups/filter/hpps" not available: No such file or directory"

I have checked to see what files are in usr/lib/cups/filter/ on a second computer running 20.04LTS which is printing OK and the usr/lib/cups/filter/hpps is there on the second computer but not on this one. how do I install it, I have searched the forums but with no answer.

@chris36 I'm hoping this might help somehow. You mentioned that you have installed 20.04 LTS but you didn't specifically say that it is Ubuntu MATE that you are using. Since this is the Ubuntu MATE forum, I will assume that it is indeed Ubuntu MATE that you are using. When I install the distribution, I make use of the Ubuntu MATE Welcome app to install the things I know I will need (codecs, drivers, etc.) and I install HPLIP from there. I have yet to have any trouble with it missing components or not working.

If you are interested in trying that, in the off-chance that it's using some tweaked version or installer that is not used by Ubuntu or other derivatives, this is what I do:
Ubuntu MATE Welcome > Getting Started > Drivers > Printers > Click the Install button next to "HP Linux Printing and Imaging System"


Hi Chris,

what you could try is to copy the contents from the folder on the PC that is working and paste them into the one that isn't!. Make a note of the file sizes of both folders and make a back up copy of the target folder before you start!. :thinking:

Also, install Synaptic (package manager) and search for both cups and HP files and compare the two results from both computers!. :grinning:

sudo apt install synaptic

Many thanks for the input, I can confirm that I am using Ubuntu Mate not Ubuntu with a Mate desktop

Hi Wolfman,
I did indeed do the copy and paste suggestion and guess what, both printers are now working!!!
Many thanks for sticking with it, it shows what this forum and the Linux community in general are all about. (off topic)Pity the rest of the world is not of the same mind.
Regards, stay safe

1 Like

That was a bit short-lived, the MFP is still working but the colour laser is returning the following
Idle - File "/usr/lib/cups/filter/hpps" has insecure permissions (0100644/uid=1000/gid=1000).
And, Idle - No suitable destination host found by cups-browsed.
Any thoughts

Hi Chris,

did you install Synaptic and compare what printer/HP/cups files are installed on the working PC?. :grinning:

Also, I recently installed a printer for a friend and had to add the printer a second time despite the fact there was a printer showing in the list, try that too!. (I don't have a printer configured on this particular computer!).

Screenshot at 2020-05-11 09-12-41

Once you have established that (if) the 2nd printer entry works (restart a few times and print a one line text doc each time to save ink). Remove the first entry if everything is okay!. :smile:

I always install Synaptic and have compared the two, I have two extra entries on this computer they are
I have the printers showing up in the list, but although I always manually enter the ip address of the printer (they are static ip`s) when setting them up they never refer to this in the device uri which they have done in the past.
I have tried the second entry trick a couple of times with no success

Hi Chris,

did you make the 2nd entry default printer?, otherwise it may address the first entry only!. :thinking: