HUD not working

HUD (heads-up display) sounds interesting, but I can’t get it to work. (Ubuntu MATE 16.10 Alpha 2)

I’ve checked Enable HUD in MATE Tweak and rebooted, but CTRL+ALT+Space does nothing. I have tried all combinations of left and right ALT and left and right CTRL keys.
Are there some unmentioned prerequisites for this feature?

I notice that there’s no HUD shortcut listed in Keyboard shortcuts. Should I add it? What is the command for HUD?

This is something new in 16.10

And I just now tried it and no go, not even in terminal.

I wonder if it could be a systemd service not starting. Anyhow I will play with it some more and see if I can aleast pin down the problem.

I will let you know what happens :slight_smile:

I forgot

Do you have synaptic package manager installed?

It will list all installed files, makes it a bit easier to figure out whats going on :slight_smile:

If your not familiar with synaptic:

Hi v3xx,

I use Synaptic all the time and I know that it can list the files for any installed package. But I don’t know what package contains the HUD software and I don’t know the text-mode command for HUD.

What did you want me to look for in Synaptic?

The package is called “mate-hud” but I cannot get it to work in 16.10 either!. :frowning: Looking for the package in Synaptic won’t do you any good!, the controls should be “Ctrl + Alt + Space” but it won’t work, it is also showing in the startup applications list!. :smiley:

For what it’s worth:

.xsession-errors shows these relevant messages:

INFO:root:Press space to handle keybinding and quit
mate-session[2576]: WARNING: Application ‘mate-hud.desktop’ failed to register before timeout
mate-session[2576]: WARNING: Application ‘mate-hud-service.desktop’ failed to register before timeout

Running /usr/lib/mate-hud/mate-hud in a terminal window enables CTRL-ALT-Space, but only for certain apps, such as mate-terminal and caja. It doesn’t work for Firefox, or even Synaptic.

Well I played with the gschema and other files until I locked up my desktop.

@wimpy will have to tell us whats going on.

this is what I have seen on HUD installation in any flavor of Ubuntu, there are some App that do not work, the site is in Spanish.


mate-hud is currently working on gtk apps only . Both gtk3 and gtk2 are supported exept that it won’t work on Client-Side decorated windows . That was in my case when I installed it . Try to use it on caja or pluma .

Hi @IvCHo,

do you mean to actually open Caja or Pluma first?. :smiley:

Hi Wolfram,
I made a short video how HUD is working for me.
This is not a public video. Only for them with the link.
Here I am not allowed to upload videos.
Click on the link to watch at my blog.


Thanks @Holgerrpl, it is appreciated!. :thumbsup: