I can't make a file executable using terminal?

I wanted to play Nullpomino tetris so I downloaded the archive and I’m supposed to launch the .exe, but nothing happens when i double click on it. I found that chmod +x is supposed to be used but that doesn’t work for me either. I navigate to the right directory using cd command and then type chmod +x nullpomino but nothing happens. I also tried selecting “Allow executing file as program” but it doesn’t work. I also tried this with Tales of Maj’Eyal but I have the sam problem.

Please help. Thanks :smile:

Sounds like you need to install Wine.

See also:




I already have Wine, that is not the problem. These are apps made for Linux. Other people start them using chmod command. I wonder whether I’m doing it wrong or there is some bug in Ubuntu Mate? Do any other people have similar problem with executable files?

If it’s an .exe file, It is for MS Windows.

You need to download this version:


Once downloaded, navigate to the compressed folder (it will probably be in your “downloads” folder) and double-left-click it to open it. Then extract the folder.

Then go into the extracted folder and double-left-click “NullpoMino” and choose “run” from the options.

I’ve just done all of the above and it works.